Cannot get FAST to run

Sorry for the novice topic on a board with a lot of high level questions. I hope to be more adept with the software in the future, but for now I am simply trying to run one of the included example files.

I downloaded and extracted FASTv7.02.00d-bjj, created the batch folder and added it to the System Variables path, and created the batch file for FAST. Then I tried to run Test01 (and others) in command prompt with no luck. I’ve been trying for some time now and found a couple of mistakes I had made when installing/calling, but I am at the point where I feel confident that I’ve installed and am invoking the code correctly. There must be something I’m missing and hope that you can help.

I’ve included a screenshot of what happens when the code is called in command prompt. If I call FAST without specifying an input file I at least get some response from FAST. When I specify an input file noting happens at all; no error message, FAST version, title line from the input file, or anything.

What should I check when receiving an output (or lack thereof) like this?
I don’t need AeroDyn or any other code to run FAST if I am not compiling it, correct?

Thanks for your time,
Kyle

Hello Kyle,

I see in the screenshot you tried 2 things:

  1. calling fast without specifying an input file (as you mentioned). In this case fast will try to use a default input file called ‘primary.fst’. This default file is not present in the folder. You can try to rename (or copy) one of the other files for example Test01.fst into primary.fst. Then it wil work.

  2. calling fast by typing ‘fast [/h] [<Test01.fst>]’ (as mentioned in the user manual). But you must leave out the brackets. Try typing ‘fast test01.fst’

If all fails you can start over and try the following steps (you dont need to create the batch folder and change the systems variables path in this example):

  1. download archive and unpack it into for example C:\fast
  2. create a text file called test.bat in C:\fast
  3. put the following two lines in the file test.bat:

fast CertTest\test01.fst
pause

  1. run test.bat

Good luck!

Thanks, Gerrit! It works when called without the brackets as you specified. I had tried a number of different ways, but apparently I didn’t try that one.
Thanks again,
Kyle

Hello,
I’m completely new here and have a similar problem to Kyle. I have followed the instructions by Gerrit and the ‘test.bat’ file cannot be found even though it is located in ‘C:\FAST\test.bat’. Any suggestions on what I might be doing wrong? I have never used FAST before nor have I seen it run so I am a complete novice.

Looking forward to any help offered.

Phillip

Hi, Phillip.

First of all, welcome to our forums. I suggest you start by reading this paper for how to set up FAST to be run from any folder: wind.nrel.gov/designcodes/papers … indows.pdf

Hopefully that will solve the problem you are having. If not, let us know.

Thank you Bonnie. I had read through that but tried the process recommended above first. I then tried the ‘Crunch’ software and followed the instructions but when I call crunch from either the folder where the .exe file is stored or from the .bat file is stored I have the response ‘Crunch’ is not recognizes as an internal or external command, operable program or batch file.

Please forgive me. I have never had to do any kind of computer work like this and I have no-one here who knows the program at all so I really am flying solo here. Apologies for my hopelessly basic questions.

Are there any step by step guides or videos other than the ones I have read that will help me understand how to operate FAST and its associated programs?

Phillip

Phillip,

It may be helpful if you post some screen shots of what you’re trying to do. But, let’s first start by trying to get you to run one of the FAST CertTest cases:

  • Download the FAST archive for Windows somewhere on your computer.
  • Double-click on the executable to expand/unzip the archive. This should place a whole bunch of files and folders on your computer, including a file called FAST.exe and a folder called CertTest.
  • Now, open a command prompt window. (Windows Start → Run… , then type “cmd” without the quotes)
  • Change the current directory to the CertTest directory that was created when you expanded the FAST archive: Type cd /d YourCertTestDir in your command window. If you expanded FAST in c:\FAST, you’d replace YourCertTestDir with c:\FAST\CertTest
  • Run test 1: Type ..\FAST.exe Test01.fst in the command window. (You’re telling the computer to call the executable called FAST.exe in the directory one level above your CertTest directory, and you’re telling the FAST executable to use the input file called Test01.fst.)

You can think of the batch file described in these instructions as a shortcut for typing …\FAST.exe or c:\FAST\FAST.exe (or whatever directory you placed the FAST executable in). It’s not necessary to set up the batch script, but you may get tired of typing more than you need to.

Hi everyone,

first of all I want to thank you for this post, has helped me a lot while trying to run FAST in my computer. I have to report a problem that I found on the “Tips Guide” there it says that when you have created the path to the batch file you don’t need to reset your compute, well in my case I had to. I tried to run fast without writting all the path to its folder and was not working till I restarted my computer. I don’t know if this is a singularity because I’m running Windows on a virtual Mac OSX machine (Parallels) but this is my case. Thank you all!

Dear Oriol,

You do not need to restart your computer, but you do need to use a new CMD window. When you modify the path, it is changed only for new processes. If you had a command window already open when you modified your path, it is not a new process so it does not use the new path. All the restart did was force you to open a new command window.

Try it. Open a command window and type “path”. Next, modify the PATH environment and retype “path” in the old command window. You will see that it is unchanged. Open a new command window and type “path”. You will see that the modified path is in effect for the new window.

Marshall

Sorry for the delay in not checking this forum…I have been on other work for the last couple of months.

I am now back on learning FAST.

The syntax I was missing. It was ‘…’ which tells the computer to look for the FAST executable in the directory above the CertTest directory I was in. Thank you Bonnie.Jonkman for that crucial nugget of information!

Here is what I ran today: -


C:\Windows\system32>cd c:\FAST\CertTest

c:\FAST\CertTest>FAST.exe Test01.fst
‘FAST.exe’ is not recognized as an internal or external command,
operable program or batch file.

c:\FAST\CertTest>\FAST.exe Test01.fst
‘\FAST.exe’ is not recognized as an internal or external command,
operable program or batch file.

c:\FAST\CertTest>…\FAST.exe Test01.fst

Running NWTC Subroutine Library (v1.07.00b-mlb, 10-Jan-2013).

Running FAST (v7.02.00d-bjj, 20-Feb-2013).

Heading of the FAST input file: FAST certification Test #01: AWT-27CR2 with ma
y DOFs with fixed
yaw error and steady wind.

Running NWTC Subroutine Library (v1.07.00b-mlb, 10-Jan-2013).

Running AeroDyn (v13.00.02a-bjj, 20-Feb-2013).
Heading of the AeroDyn input file: AWT-27CR aerodynamic parameters for FAST ce
tification test
#1.

Running NWTC Subroutine Library (v1.07.00b-mlb, 10-Jan-2013).

Using InflowWind (v1.01.00b-bjj, 10-Aug-2012)

Assuming .\Wind/AWT27/Shr12_30.wnd is a formatted HH wind file.

Running NWTC Subroutine Library (v1.07.00b-mlb, 10-Jan-2013).
Reading 3 lines of data from the HH wind file.

ADAMS dataset file ‘Test01_ADAMS.adm’ created.
ADAMS command file ‘Test01_ADAMS.acf’ created.

Total Real Time: 2.16 seconds
Total CPU Time: 2.028 seconds
Simulated Time: 20.004 seconds
Time Ratio (Sim/CPU): 9.8638

FAST terminated normally.

Many thanks for all your help.

For some reason I have never got into computers or how they run. I can use software after a little training and I have my MEng in aerospace so I have the theory, but sadly at my age (only 29) the university just assumed that everyone knows how to use computers. I spent my childhood designing and flying radio controlled aeroplanes and sailing dinghies…I just never sat in front of a computer if I could help it!

Hi, I am new to the program as well and trying to learn how to use FAST.
I’ve created the batch file with the FAST executable and followed directions on the instructions above.
It seems like the batch file is working but when it runs with the input, it does not want to.
What can I do with this to solve?

Thank you.

I’d guess you are missing a blank space in your batch file between the name of the FAST executable and the arguments (i.e., make sure there is a blank space between FAST.exe and %1). Also, the “/h” switch will just make FAST print a help message, so don’t use it when you want to run a simulation.

Your batch file (FAST.bat) should look like this:

"c:\DesignCodes\FAST\FAST_v8.10.00a-bjj" %1 %2 (the %2 is optional)

Then you can run it using this:

FAST Test01.fst

Thank you I think it is executing what I want now.
But instead of the simulation, it is executing the winzip GUI and nothing else.
Capture.JPG

So, apparently you are telling it to run is the self-extracting archive. You should run that self-extracting archive one time only (which it looks like you’ve done). When you extract the files from the archive, it will create an executable file called FAST_Win32.exe in a folder called “bin”. Your batch script should be calling that FAST_Win32.exe (or FAST_x64.exe) executable.

Your batch file should actually say this instead:

"C:\FAST\bin\FAST_Win32.exe" %1 %2

Sorry for the confusion. I based my previous answer on what I thought you had named the FAST executable, not realizing that that was the name of the self-executing archive.

Hello everyone, please i am having a novice problem. I have tried to run one of the fast test cases and i have not been successful. I have tried everything and i do not seem to know what the problem is. I decided to post on here as a last resort. Please help. bellow is what i did and the error message i got.

Kind regards

C:\Users\Chukwudera Okafor>/d C:\Design\CertTest
‘/d’ is not recognized as an internal or external command,
operable program or batch file.

C:\Users\Chukwudera Okafor>cd /dC:\Design\CertTest

C:\Design\CertTest>…\FAST.exe Test01.fst
‘…\FAST.exe’ is not recognized as an internal or external command,
operable program or batch file.

C:\Design\CertTest>…FAST_Win32.exe Test01.fst
‘…FAST_Win32.exe’ is not recognized as an internal or external command,
operable program or batch file.

C:\Design\CertTest>

You need to get the path and name of the FAST executable correct so that it can run.

If you are using a “normal” FAST v8 distribution, the command from the CertTest folder is[code]…\bin\FAST_Win32.exe Test01.fst

[/code]

Thank you for your reply Bonnie
I am trying to Run FAST and i am getting an error. I dont know why it is saying the file could not be found because i put all the Test02 files in the bin folder.
I tried with different input files aswell and still got the same error.
I will please also like a little explanation about these input files (26 of them) what exactly do the represent? different scenarios? if so different scenarios of what?
Because at the moment i am just trying to get FAST to run successfully, but once it is running i will like to know which of the input files are appropriate to my study.

C:\Design\bin>FAST_Win32.exe Test02.fst


FAST (v8.15.00a-bjj, 12-Apr-2016)

Copyright (C) 2016 National Renewable Energy Laboratory

This program comes with ABSOLUTELY NO WARRANTY. See the “license.txt” file distributed with this
software for details.


Running FAST (v8.15.00a-bjj, 12-Apr-2016), compiled as a 32-bit application using single
precision
linked with NWTC Subroutine Library (v2.08.00, 5-Apr-2016)

Heading of the FAST input file:
FAST Certification Test #02: AWT-27CR2 with many DOFs with startup and shutdown and steady wind

Running ElastoDyn (v1.03.02a-bjj, 8-Apr-2016).

FAST_InitializeAll:ED_Init:ED_ReadInput:ReadPrimaryFile:OpenFInpFile:The input file,
“.\AWT27/Test02_ElastoDyn.dat”, was not found.

FAST encountered an error during module initialization.
Simulation error level: FATAL ERROR

Aborting FAST.

Dear Odera,

It looks like you transferred the Test02.fst file from the CertTest to the bin directory, but my guess is you didn’t transfer the AWT27 directory from the CertTest to the bin directory, which also contains files needed to run Test02. Alternatively, without moving any files around, you can run FAST as Bonnie stated in her post:

…\bin\FAST_Win32.exe Test02.fst

The files FAST v8 needs to run are shown in Figure 4 of the ReadMe file: wind.nrel.gov/nwtc/docs/README_FAST8.pdf. The 26 test cases in the CertTest folder are summarized in Table 5 of this ReadMe file.

See the “Running FAST” section of the ReadMe file for more information.

Best regards,