TurbSim 1.06.00 (stable) missing source code

i tried to compile the sources of the current stable TurbSim (1.06.00), and i get this error:

[  7%] Building Fortran object CMakeFiles/TurboSim.dir/Source/RNG/RANLUX.f90.o

   use     SysSubs
Fatal Error: Can't open module file 'syssubs.mod' for reading at (1): No such file or directory

so i assume the package does not contain the whole source code. where can i get the whole source?

and as this is a good opportunity…
i would like to ask for a public git repo for the TurbSim sources again!

TurbSim v1.06 uses code from the NWTC Subroutine Library, which is not part of the TurbSim archive. You can get the version necessary here: nwtc.nrel.gov/Legacy-NWTC_Library

Also, we are in the process of moving our SVN repositories to gitHub and hope to have them available later in the year.

thanks bonnie! :slight_smile:
it worked with NWTC_Library v1.07.02a-mlb (does not work with newer version, did not try older ones).

Hey there,

I have a similar question. Is the source code with an accompanying makefile available for v 1.06.00? I’d like to compile it on a mac, and I didn’t find it on nwtc.nrel.gov/TurbSim .

Bryce Ingersoll