Problem installating FAST v.8

Good evening.

I have downloaded FAST v8 and installed it in my laptop without problem (the 64-bit version) but, in my work’s computer (it’s a bit older), doing the same proccess to install the program (the 32-bit version), when I run it I obtain the following message:

“…FAST_Win32.exe is not a valid Win32 application”

This computer have the Windows XP SP3 (32-bits). I’ve tried downloading the file another time but the problem remains and I’ve installed it in another computer of the office (with the same OS) and I’ve obtained the same message. I know the files aren’t corrupted because it runs in my laptop.

I want to know, if it is posible, if there is any known incompatibility between FAST v8 and this OS or if someone had the same problem and could fix it.

Thank you in advance.


Hi, Marcos.

It is possible that this could be related to one of the linking options we use in FAST v8, where we increase the stack reserve size. How much memory is available on your XP machine?

Thank you for answering,

The computer has the following specifications:

Processor: Intel(R) Core™2 Duo CPU E6550 @2,33GHz 1,98GHz
RAM: 1.99 GB
Hardrive: 295 GB (219GB free)

Operating System : Microsoft Windows XP Professional v2002 (SP3)

Best regards,

I don’t see anything with those numbers that would necessarily indicate a problem, but if you have first confirmed that the executable didn’t get corrupted in the download or extracting process, my next guess would be to recompile without the /STACK linking option.

Good evening,

I have tried to install it without the stack linking option and nothing changes. Then, I have tried to install it in another three computers at work (all of them with OS Windows XP SP3) and the problem remains. I’m sure it isn’t a problem related with the downloading or the extracting proccess because I’ve tried to install it with both copying the files from my laptop (where it runs) and with the original downloaded files (extracting it in the computers at work).

It appears like there is some kind of incompatibility between Windows XP SP3 and Fast v8 that doesn’t allow to run the FAST_Win32 file. If it helps, Fast v7 works without problem in these computers but I don’t understand what changes.

Thank you for answering.

Best regards,

We use another linking option, /LARGEADDRESSAWARE, which is supposed to allow the compiled 32-bit code to use more than 2 GB of address space when run on 64-bit hardware. It is not supposed to cause issues with running on 32-bit hardware, but I suppose it could be a problem on older systems like Windows XP. You could try to recompile without that option, or just compile FAST on an XP machine and see if you can get it to run.

XP isn’t a supported operating system, though, so I’m not sure I can provide any more help on this.

Good luck.

Good morning Bonnie,

Finally, we decided to install Windows 7 in one computer and the problem have disappeared.

Thank you so much for all the help received.

Best regards,