Meshing error?

Dear Dr.Jonkman,

Thank you for your time and attention.

I am developing a simulation for the 7MW Levenmouth turbine. I have received the turbine parameters and I have started to introduce them into the input files.
My first goal is to simulate an onshore configuration.
After building the main input file along with the ElastoDyn, the blades, the tower, the InflowWind, the AeroDyn and the ServoDyn input files, I tried to run FAST.
I have got the next error:
FAST_InitializeAll:InitModuleMappings:ED_L_2_AD_L_T:MeshMapCreate:CreateMotionMap_L2_to_L2:CreateMapping_ProjectToLine2:Node 10 does not project onto any line2 element.
I am not sure if this is a problem with the input data, but I suspect it is a problem regarding nonmatching meshes (
Could you kindly help me to overcome this issue?

With Regards,

Dear Jordi,

It appears that FAST is aborting because of an error in the mesh-mapping search for ED_L_2_AD_L_T, which is the mesh-mapping search between the ElastoDyn Line2 tower motion output mesh and the AeroDyn Line2 tower motion input mesh. FAST will trigger this error e.g. if the tower in AeroDyn starts lower than the tower in ElastoDyn or if the tower in AeroDyn ends higher than the tower in ElastoDyn.

I hope that helps.

Best regards,

Dear Jason,
Thank you very much. It was helpful.
With Regards,

Dear Jason

I am current receiving the same error Jordi experienced

InitModuleMapping:ED_L_2_AD_LK_T:MeshMapCreateL:CreateMotionMap_L2_to_L2:CreateMapping_ProjectToLine2:Node 1 does not project onto any line2 element.

To clarify the advice you provided previously in the thread, is the accurate to say that the tower height properties in the AeroDyn input file should begin at the TowerBsHt specified in the ElastoDyn file or am I interpreting your suggestion incorrectly?

I have attached my AeroDyn and ElastoDyn files for reference. Please let me know if you need other information regarding the geometry.

Thank you.
M.C. Anderson
Hybrid_10MW_AeroDyn15.txt (9.91 KB)
Hybrid_10MW_ElastoDyn.txt (11.9 KB)

Dear M.C. Anderson

Your understanding is correct. I’m a bit surprised that the files you are using are triggering this error. Perhaps there is some numerical round-off that is preventing the mapping from functioning properly? Try adding a small epsilon to TwrElev(1) or subtracting a small epsilon from TwrElev(89) in your AeroDyn v15 input file to see if the problem goes away.

Best regards,

That did the trick. Thank you so much.