Error: FF wind array was exhausted

With FAST version 8, usin the turbine model (test_22) “NREL 5.0 MW Baseline Wind Turbine with ITI Barge” when i run the simulation i have this error message:

Error using Run_Baseline (line 35)
Error reported by S-function ‘FAST_SFunc’ in ‘Sta_saludable/FAST Nonlinear Wind Turbine/S-Function’:
FAST_Solution:CalcOutputs_And_SolveForInputs:SolveOption2:AD_CalcOutput:IfW_CalcOutput:CalculateOutput:IfW_FFWind:CalcOutput [position=(0, 0, 90)]:
Error: FF wind array was exhausted at 66.062 seconds (trying to access data at 72.104 seconds).

Which can be the reason of this error? Im using the same wind that i use with the test_21 and i never had problems.

Christian Tutivèn

Dear Christian,

It looks like you’ve extended the length of the Test 22 simulation. The FAST CertTest only provides sample input; the wind files in particularly were purposely made very short to reduce the size of the FAST archive. You should run TurbSim to generate the turbulent wind data that you need for your own use:

Best regards,

Hi Jason,

I am trying to run FAST for 700 sec and it keeps giving me this error.

FWind_CalcOutput [position=<NaN, NaN, NaN> in wind-file coordinate]:
Error: FF wind array was exhausted at 508.85 seconds (trying to access data at NaN seconds).

I generated wind file with Turbsim for 700 sec (AnalysisTime and UsableTime both 700 sec) and used it in my FAST input but I dont know why it still gives me error?

It is interesting that for PropogationDir =120 degrees it gives error, while for other values of PropogationDir (0 , 30 , 60, 90, 150) it runs without errors.

I am trying to run FAST for different wind directions.

Thank you very much for your invaluable support.

Best Regards,

Arash Hemmati,

Dear Arash,

My guess is that the problem is not with the wind file, but that your model is going numerically unstable for some reason. Are you getting a warning about a “small angle approximation violation” before this error?

Without knowing more about your simulation settings, it’s hard to know that what the problem is. Please use “Search…” in the upper right of the forum to search for “unstable” to see how others have solved similar problems in the past.

Best regards,

Hi, All -

I wanted to post a similar issue I am having with FF wind array exhausted at a seemingly random time in the simulation. I have triple-checked the grid, and I cannot see how the turbine could violate the grid boundaries. I have also checked several of the output parameters to identify if I’m getting resonance or if the model appears to be going unstable. Unless the instability occurs instantaneously at the time this error is generated, I am not seeing it. I am running FAST8 ElastoDyn only (no BeamDyn). Any insight as to what other things I should be checking to identify the cause of this error? It’s occuring about 300s into a 620s sim.

Thanks in advance for your help.


Edit: I should also clarify that I am running this using a very basic Simulink model for pitch control/variable speed. This is a parked load case, so pitch is fixed at 90deg and the machine is idling as expected (<1rpm). I also have the following details from the error message that were not given in the above forum post:

SolveOption2:AD14_CalcOutput/Inflow:Inflow:infdist:MATINV:gaussj: Singular matrix encountered

Dear Ryan,

If you are confident that the grid is large enough to encompass the rotor under deflection, than the only problem I can think of is numerical instability leading to large deflection. Are you getting the “small angle approximation violation” warning?

You mention that you are modeling an idling rotor, but are receiving an error from AeroDyn v14 subroutine infdist(). However, this subroutine is only used by the generalized-dynamic wake (GDW) model of AeroDyn v14 (DYNIN option). For an idling rotor, it is normally recommend to disable all wake calculations, i.e. set IndModel = NONE, which will disable GDW. Perhaps GDW is driving the model unstable for your case.

Best regards,

Dear Jason

I want to generate a wind field from TurbSim and put it in FAST.Farm, but it keeps giving me this error: “Error: FF wind array was exhausted at 2 seconds (trying to access data at -0.22222 seconds)”.

The steps I followed are :
(1) I Create a .bts file of wind field 1700m wide, 160m high, without turbulence and 18m/s at hub-height (90m), using TurbSim as following:

(2) I Put the file (Sample5MWTurbSim.bts in my case) in a folder named “Wind” and refer to it in the InflowWind.dat file of FAST.Farm:

(3) I Put the same grid size and points in FAST.Farm input file (.fstf) as the ones generated by TurbSim, and refer to InflowWind.dat in “InflowFile”:

(4) Finally, I run FAST.Farm, and it gives me the following error:



Copyright (C) 2017 National Renewable Energy Laboratory

This program is licensed under Apache License Version 2.0 and comes with ABSOLUTELY NO WARRANTY.
See the “LICENSE” file distributed with this software for details.

Compile Info:

  • Architecture: 64 bit
  • Precision: single
    Execution Info:
  • Date: 01/21/2021
  • Time: 13:35:33+0100

Heading of the FAST.Farm input file:
Sample FAST.Farm input file
Running AWAE.
Running InflowWind.

Reading a 171x17 grid (1700 m wide, 10 m to 170 m above ground) with a characteristic wind
speed of 18 m/s. This full-field file was generated by TurbSim (v1.50, 25-Sep-2009) on
21-Jan-2021 at 12:52:42.

Processed 1945 time steps of 10-Hz full-field data (194.4 seconds).

Farm_Initialize:Farm_ValidateInput:OutFmt produces a column width of 10 instead of 14 characters.
Farm_Initialize:For efficiency, NumPlanes has been reduced to the number of time steps (51).
Farm_Initialize:InflowWind_CalcOutput:CalcOutput:IfW_TSFFWind_CalcOutput [position=(890, 0, 10)
in wind-file coordinates]: Error: FF wind array was exhausted at 2 seconds (trying to access data
at -0.22222 seconds).


Aborting FAST.Farm.[/code]

Can you help me with the issue ? Is it the right way to include a TurbSim file in FAST.Farm?

Kindest regards


Dear Younes,

Just a few comments:

  • The wind data is shifted when read by InflowWind. As such the FAST.Farm documentation recommends generating the full-field wind data files periodically so that the wind domain in InflowWind effectively extends forever along the wind propagation direction. This can be achieved by setting UsableTime = “ALL” in TurbSim.
  • The wind data generated by TurbSim is centered around Y=0. So, you should set Y0_Low in FAST.Farm equal to -GridWidth/2 from TurbSim and locate the turbines appropriately (likely with WT_Y near zero).
  • I would only use the TurbModel = NONE option for debugging purposes. You can define wind without turbulence more simply through WindType = 1 or 2 in InflowWind (without the need to use TurbSim).

I hope that helps.

Best regards,

Dear Jason,

I noticed that I was using old versions of TurbSim and its input files. I took the last versions by building the TurbSim.sln in the OpenFAST directory, and it works now. Thank you so much for the comments, it helped a lot and worked well also.

Kindest regards