SOWFA Support

Hi all,
I’m trying to install SOWFA but the compilation (Allwmake) ends with this error:

In file included from horizontalAxisWindTurbinesALMfastv8/horizontalAxisWindTurbinesALMfastv8.C:36:0: horizontalAxisWindTurbinesALMfastv8/horizontalAxisWindTurbinesALMfastv8.H:68:29: fatal error: FAST_cInterface.h: File or directory not found #include "FAST_cInterface.h" ^ compilation terminated.
I have compilated FAST but in the FAST directories I did not find this file “FAST_cInterface.h” nor I found it in :open_mouth:
Could someone tell me if and where I am going wrong? :unamused:
Thank you!

Hello Everyone,

I have recently installed OpenFOAM 2.4.0 and compiled the latest SOWFA code on top of it. I am using UT Austin’s TACC supercomputer Stampede2.

When I try to run the example casefiles with ABLSolver, I am getting a “Floating Point exception” error. I was able to run blockMesh, checkMesh and SetFieldsABL commands without getting any errors.

I have checked the case files and nothing seems out of line with the initial values specified. I have tried with every tutorial case and ended up with the same error. However, I was able to run cases in OpenFOAM without this error. So, I am guessing this is specific to SOWFA. When I looked online regarding this error, some suggesting issuing “unset FOAM_ SIGFPE” command. I’ve tried this but getting the same error.

Please help regarding this issue.

Thank you

I have successfully ran the windPlant tutorials for all the ABL conditions. I am wondering if it is possible to be able to use local wind data to create a windPlant simulation near my location? If so, what would be the best way to incorporate local data into my simulations?

Or would I just have to run simulations using averages over my set time frame?

Hi Yilei.Song

I also want to use precursor data as inflow conditions to run example case ADM turbine or ALM turbine. But the precursor data folders haven’t been added to the SOWFA directory because they were too big. Do you have any idea of how to create/get precursorDir file or others to run this tutorial cases?
For example, this is what is asked as precursor to run the example case (from runscript.solve.1):

I think as you mentioned that boundaryData can be created using files such as “” but for driving sources I have no idea how to proceed. I do not really understand actually what are these driving sources.

If you manage to solve this problem tell me, or if someone knows how to proceed please let us know.


Dear all,

Is the solver ABLTerrainSolver working for you?

For me, it’s not working. I’ve tried running in debug mode and I get the following error: #6 0x000000000043b359 in main (argc=1, argv=0x7fffffffbec8) at createDivSchemeBlendingField.H:42
This is the content from the 42th line: profileTableOld = profileTable;

Since there are no examples on GitHub I don’t know how to solve this issue.

I would very much appreciate your help.

Thank you,

Dear Eugen,

I never get this error for instance, what is your case setup (boundaries, mesh, …)?

Is there a reason you are using ABLterrainsolver instead of the ABLsolver?

I have a problem istalling SOWFA-1c359de. I use openfoam 2.4.x wich is preinstalled on my terminal from University. When i run Allwclean, there comes fatal Error: horizontalAxisWindTurbinesALMAdvanced.H: no such file or directory.

Any ideas how to handel this?

kind regards

Are you able to figureout how to solve this issue, please help me, iam stuck; mail me at


When i was running example.ADM i encountered withe the following error.please help

Time = 20145.5 Time Step = 40291
Courant Number mean: 0.299860887324 max: 0.41506723414
PIMPLE: iteration 1
<U_1> = (5.32997659191 0.195153404911 -0.00904748281988) <U_s> = (3.3316336642 0.133134102186 0) <dU/dn> = (0.137141181314 0.00425622665763 -0.00124181136743)
DILUPBiCG: Solving for Ux, Initial residual = 0.00856587251151, Final residual = 1.58274808219e-07, No Iterations 3
DILUPBiCG: Solving for Uy, Initial residual = 0.0119671718047, Final residual = 2.12107870702e-07, No Iterations 3
DILUPBiCG: Solving for Uz, Initial residual = 0.0456909217966, Final residual = 8.4202657728e-07, No Iterations 3
DILUPBiCG: Solving for T, Initial residual = 0.00062633029353, Final residual = 1.22875379823e-07, No Iterations 3
GAMGPCG: Solving for p_rgh, Initial residual = 0.0601739916016, Final residual = 0.000286707860098, No Iterations 1
<U_1> = (5.32960404611 0.194998450267 -0.00905510913384) <U_s> = (3.3310199578 0.133136167178 0) <dU/dn> = (0.137157731551 0.00424545080023 -0.00124285811641)
DILUPBiCG: Solving for T, Initial residual = 3.56520215837e-05, Final residual = 4.73860796406e-07, No Iterations 1
GAMGPCG: Solving for p_rgh, Initial residual = 0.00257877220385, Final residual = 1.51627089236e-05, No Iterations 2
<U_1> = (5.32963068884 0.194998472112 -0.00905385749337) <U_s> = (3.33104639494 0.1331360321 0) <dU/dn> = (0.137157745659 0.00424546156944 -0.00124268632262)
DILUPBiCG: Solving for T, Initial residual = 3.4470946218e-05, Final residual = 4.36729152486e-07, No Iterations 1
GAMGPCG: Solving for p_rgh, Initial residual = 0.00202161695809, Final residual = 7.01190760993e-07, No Iterations 3
<U_1> = (5.32963226568 0.194998481116 -0.0090539768129) <U_s> = (3.33104792486 0.133136043918 0) <dU/dn> = (0.13715774888 0.00424546137636 -0.00124270269981)
DILUPBiCG: Solving for T, Initial residual = 1.94327813797e-06, Final residual = 3.3395606206e-08, No Iterations 1
Local Flux Continuity Error: Min 1.52919942504e-14 Max 3.11084414644e-06 Weighted Mean 3.34572808239e-09
Total Boundary Flux: -5.15979081683e-09
Total Boundary Area: 28524636.7347
Momentum Driving Source Term: (0.000216793650368 0.000757503264606 0) m/s^2
Temperature Driving Source Term: 0 K/s
[3] error in IOstream “/media/VM_Shared_Dir/mmanaf-2.4.x/MyCases/test2/ADM_case2/constant/boundaryData/west/20146/k” for operation operator>>(Istream&, List&) : reading entry
[3] file: /media/VM_Shared_Dir/mmanaf-2.4.x/MyCases/test2/ADM_case2/constant/boundaryData/west/20146/k at line 498.
[3] From function IOstream::fatalCheck(const char*) const

MPI_ABORT was invoked on rank 3 in communicator MPI_COMM_WORLD
with errorcode 1.

NOTE: invoking MPI_ABORT causes Open MPI to kill all MPI processes.
You may or may not see output from other processes, depending on
exactly when Open MPI kills them.

[3] in file db/IOstreams/IOstreams/IOstream.C at line 114.
FOAM parallel run exiting

I have the samehelp could you please help

Hi everyone,

I compiled SOWFA from github together with OpenFoam 2.4.x after having some issues with the .H files I managed that and the compilation finished without errors (except for the OpenFAST Solvers, see below).

Nevertheless, when trying to run the ABL.flatTerrain example cases I encounter the following error as also stated similar by others already:

→ FOAM Warning :
From function dlOpen(const fileName&, const bool)
in file POSIX.C at line 1179
dlopen error : /home/ms-sowfa/OpenFOAM/SOWFA-2.4.x/lib/linux64GccDPOpt/ undefined symbol: _ZTIN4Foam14incompressible9LESModels11GenEddyViscE
→ FOAM Warning :
From function dlLibraryTable::open(const fileName&, const bool)
in file db/dynamicLibrary/dlLibraryTable/dlLibraryTable.C at line 99
could not load “”

I read in other posts this warning is not relevant for the old SOWFA version, but already the blockMesh does not seem to finish and is not creating any points. Furthermore I read lincompressibleLESModels should be included in the make/options file. It is included, so I wonder (as it is stated “” could not be load) if lSOWFAincompressibleLESModels needs to be included or if there is a error somewhere else? I am completely new to this topic and hence not quite sure how the libary linking works.

Moreover I encountered the error

OPENFAST_DIR is set to ‘/home/ms-sowfa/openfast’. Attempting to compile OpenFAST pisoFoam solver.
Making dependency list for source file pisoFoamTurbine.C
could not open file OpenFAST.H for source file pisoFoamTurbine.C due to No such file or directory
SOURCE=pisoFoamTurbine.C ; g++ -m64 -Dlinux64 -DWM_DP -Wall -Wextra -Wno-unused-parameter -Wold-style-cast -Wnon-virtual-dtor -O3 -DNoRepository -ftemplate-depth-100 -I/home/ms-sowfa/OpenFOAM/OpenFOAM-2.4.x/src/turbulenceModels/incompressible/turbulenceModel -I/home/ms-sowfa/OpenFOAM/OpenFOAM-2.4.x/src/transportModels -I/home/ms-sowfa/OpenFOAM/OpenFOAM-2.4.x/src/transportModels/incompressible/singlePhaseTransportModel -I/home/ms-sowfa/OpenFOAM/OpenFOAM-2.4.x/src/finiteVolume/lnInclude -I/home/ms-sowfa/OpenFOAM/OpenFOAM-2.4.x/src/meshTools/lnInclude -I/home/ms-sowfa/OpenFOAM/OpenFOAM-2.4.x/src/fvOptions/lnInclude -I/home/ms-sowfa/OpenFOAM/OpenFOAM-2.4.x/src/sampling/lnInclude -I/home/ms-sowfa/OpenFOAM/SOWFA-2.4.x/src/turbineModels/turbineModelsOpenFAST/lnInclude -DOMPI_SKIP_MPICXX -I/usr/lib/openmpi/include -I/usr/lib/openmpi/include/openmpi -pthread -IlnInclude -I. -I/home/ms-sowfa/OpenFOAM/OpenFOAM-2.4.x/src/OpenFOAM/lnInclude -I/home/ms-sowfa/OpenFOAM/OpenFOAM-2.4.x/src/OSspecific/POSIX/lnInclude -fPIC -c $SOURCE -o Make/linux64GccDPOpt/pisoFoamTurbine.o
In file included from pisoFoamTurbine.C:38:0:
/home/ms-sowfa/OpenFOAM/SOWFA-2.4.x/src/turbineModels/turbineModelsOpenFAST/lnInclude/horizontalAxisWindTurbinesALMOpenFAST.H:68:22: fatal error: OpenFAST.H: Datei oder Verzeichnis nicht gefunden
#include “OpenFAST.H”
compilation terminated.
make: *** [Make/linux64GccDPOpt/pisoFoamTurbine.o] Fehler 1

for the OpenFAST compilation. Where exactly does the $OPENFAST_DIR need to be stated to to be able to find the OpenFAST.H file and which Path should $HDF5_DIR have? (I compiled OpenFAST from github in /home/ms-sowfa/openfast)

Thanks a lot for all the help provided within in the community and thanks a lot in advance for an answer.

Regards Merle

Dear All

I would like to know if it is possible to run SOWFA using RANS instead of LES for a time-domain simulation to get a time series of power, torque, and others?


Hello all,

Can SOWFA work with more latest versions of OpenFOAM like 1912?


Hi dear all,
i installed and compiled SOWFA with OpenFoam_2.4.x in Ubuntu 16.04, but
SOWFA does not have Super Controller, can you tell me how can i add Super
Controller in SOWFA?

Best Regards,

Dear Srinivasa

I also want to use other new versions of OpenFOAM, because these old versions are not so easy to use. Now I want to use OpenFOAM-7. So I want to know if you get the clear answer about using higher version of OpenFOAM?




I am a new SOWFA user and new to LES in general. I have just ran my first successful case in SOWFA, but some of the results aren’t what I expected.

I used the example.ABL.flatTerrain.neutral and example.ALM cases included with SOWFA with only minor modifications (one turbine instead of two). Because this was just a test case, I also didn’t run the precursor for the full 20000s that was recommended (only 9600, but the planar averaged velocities did seem to be reasonably converged). I ran the turbine simulation from 9600 to 10400s.

One of the first things I wanted to check was how much of the turbulent kinetic energy had been resolved by the mesh. I expected this to be significantly lower than the recommended 80% for a good LES because I’ve read in a couple of places that these meshes (10m in most of the domain) are considered very coarse.

But I was surprised to find that my resolved TKE wasn’t just small. It was basically zero throughout the domain. If I had set up this case myself, I would assume I had done something badly wrong, but because this is an example case, I thought it appropriate to post here.

Why might this happen? Surely the example mesh isn’t so coarse that it can’t resolve any of the TKE? Indeed, I can clearly see turbulent eddies in the instantaneous velocity field. Have I gone wrong somewhere? Or is there something I haven’t understood?

Thank you for your time,

hi Marshall and SOWFA enthusiasts,

I used SOWFA to study the wake of wind turbines. I calculated the conditions with six wind turbines. The six wind turbines were arranged in two rows(as shown in the figure below). The pre-simulation time is 20000s, and the wind turbine simulation time is 4000s. The incoming wind speed is 8m/s. Most of the other parameters are set using the values given in the case. I took the result of 1200s after the calculation time to calculate the time-mean streamwise velocity. There is a strange phenomenon in all the calculation results. The inflow wind speed of the wind turbine near the inflow position in the top row is significantly lower than that in the bottom row (as shown in the figure below, the short black lines represent the wind turbines). Can anyone explain this phenomenon?

Thank you for your help,

Liu Mingqiu

Hi Mingqiu,

The differences in the wind field probably exist in your background flow as well. You should take a look at your precursor simulation to see if the flow patterns exist in time-averaged slices there as well. I suspect that your domain is too small. (E.g., if D~100 m, then the extent is only 2.4km. We typically simulate domains with 3-5 km extent in the horizontal direction.) If this is the case, then you’ll see very long high/low-speed flow streaks that have “locked on” between periodic boundaries, resulting in an effectively infinitely long flow structure.

Another detail of interest (that should be further investigated) in your result is the very different induction regions between the leading turbines. This could be a consequence of the background flow combined with your turbines being too close to domain boundaries. I don’t have any great rules of thumb here, but I would put a kilometer between the turbines and the boundaries.


Hi Eilot

Thank you for your answer. I did not save the slices of the precursor simulation, and I plan to recalculate to see if there is a problem. In addition, the diameter D is 126m. The simulate domain meets the requirement of 3-5km.

As for your other suggestion, in fact, we calculated many working conditions and also considered this possibility. We calculated a case where the wind turbines are 10D (1260m) away from the boundary. As shown in the figure below, the results still show the same phenomenon. I wonder if there are other reasons for this strange phenomenon.

Liu mingqiu