Meshing mapping error message

Dear @Cao.Yuming,

From my brief review of your input files, the only obvious issue I see is that you have eliminated precurve from your BeamDyn model while keeping precuve from your AeroDyn model. The offset between the aerodynamic and structural nodes will result in the aeordynamic loads generating large moments due to the moment arm. I’m not sure if this is causing the lack of convergence your model is facing, but that could be a problem.

As with any lack of convergence issue, I would first simplify the model further to debug. Does the model run as expected if you disable all ElastoDyn DOFs? If so, which DOF, when enabled, causes the model to lack convergence?

I know that your time step is already small and you are using one correction step at the OpenFAST driver level and only a lower-order element in BeamDyn. But doesn’t reducing the time step further help with convergence?

Best regards,

Dear @Jason.Jonkman

If I put BlCrvAC=kp_xr and BlSwpAC=kp_yr, and meanwhile set the time step to 0.0002s, it will report an error but the program will continue. When I set the pre-bend value in both BeamDyn(kp_xr, kp_yr) and AreoDyn(BlCrvAC, BlSwpAC) to 0, and meanwhile set the time step to 0.0002s, the program works fine. Otherwise it still reports an error and Interrupt.

Best regards,