Error in the blade pitch control system

Dear Jason:
Hi, sorry to bother you, but I got a confusing problem when I am using FAST-orcaflex coupling. And the situation is that I have no clue about what the problem excatly is. So…
Here are my questions:

  1. I used the Turbsim and generated a wind field for 10 seeds with Uhub=24m/s and the turbulence Intensity 0.12 and the related Hs=8m, Tz=8.5. Using the Hywind control system DISCON_OC3Hywind_x64.dll, I set the initial blade pitch as 0.
    After the simulations were done, I checked the .out file and found out the bldpitch was like the attachment.

This kind of cycle continued and there was no error or warning reported during the simulation. This was found in some seeds yet not in the others. Meanwhile, this phenomenon was also found in the wind speed 22.4m/s related sea state and the wind speed 25.5m/s related sea states, but not in the sea state whose wind speed are low.
so what is this about?

  1. During the coupling simulation, I encountered this error:

Fwind_calcOutput [position=<NaN,NaN,NaN> in wind-file coordinates]: Error: FF wind array was exhausted at 6654 seconds .

I guessed that this is because the wind field grid is too small, but I am not sure about it.
QQ图片20130602220111.png

Dear Sean,

I’m not sure, but do you get the same problem if you initialize the pitch angle more appropriately for the wind speed, as we typically recommend: http://forums.nrel.gov/t/initial-conditions-for-tower-and-rotor/609/1? At 24 m/s, the mean pitch angle for the NREL 5-MW turbine should be around 22 deg; at 22 m/s, the mean pitch should be around 20 deg.

If you believe your wind file is of sufficient size to encompass the rotor throughout the simulation when it runs properly, than the error you are getting regarding the exhausted FF wind array is likely related to numerical problems associated with the large jumps in pitch angle, likely preceded by a warning about a “small angle approximation violation”.

Best regards,

Dear Jason,
Hi, thanks for answering my questions so soon. I tried your advice about changing the initial pitch angle but that didn’t help. Thanks anyway, and I’ll try some other way to fix it, and if it still doesn’t work, then I may ask you again~~
Thanks for your kindness.
Best Regards.
Sean Wu