Application Start Error

Hi All,

I’m trying to get openfast up and running but have been having some trouble.

I am attempting to compile the IEA-15MW monopile turbine on a x64 bit windows machine. I have installed intel fortran, downloaded the binaries, inserted the .exe and dlls into the 15-MW monopile folder, and edited the ServoDyn file to point to the Discon.dll( as seen in attached image).

I am getting the error "The application was unable to start correctly (0xc000007b) " as seen in the attached image below.

Any help would be greatly appreciated,
Kind Regards,

Dear Breen,

Did you compile OpenFAST yourself? Can you run any of the sample OpenFAST simulations from the r-test? Have you tried running OpenFAST with the precompiled binary executables provided for Windows users?

Best regards,

Dr. Jonkman,

Thank you for your help.
I compiled it myself. Am I correct in assuming that the Win32 file is the only .exe file suitable for windows?

Kind regards,
Breen Elliott

Hi Breen,

You can use the Win32 file, but I would generally recommend using the 64-bit version, OpenFAST_x64.exe.

Best regards,

Dr. Jonkman,

I can run the openfast_win32.exe file, however I cannot run openfast_x64.exe or openfast_x64_double.exe. I get the error in the original attached image.

My machine is 64 bit so I don’t know what is wrong. Do you have any suggestions?

Kind regards,
Breen Elliott

Hi Breen

Try running the 64 bit executables with the version flag and share the output here. For example,

.\openfast_x64.exe /v

Dr. Jonkman,

I’m not sure if I have to do anything other than what I have done in the image attached for the version flag?

Thank you for your help,

Ok this indicates in issue with your computer’s environment rather than a problem in your model (i.e. the fst file). I suggest that you download the binaries from the OpenFAST Release page ( and see if those work from both version 2.4.0 and 2.5.0. You can use the same command (“openfast.exe /v” with no other additional arguments) to check if it will run.

Try downloading the precompiled binaries from the latest OpenFAST release page and install the required Intel libraries linked at the end of the release note: … tag/v2.5.0

Hi Rafael,

I re-started from scratch and can now run the x64.exe files.

Thank you for your help!

Kind regards,
Breen Elliott

Dear Dr.Jonkman,
I am able to successfully run 15MW openFAST executables in a machine which is not having Matlab now.But earlier when I tried to run in a machine that had Matlab installed in it I got this DLL error while initiating the run

As I do most of my postprocessing in Matlab it would be nice to have them both in one machine.Any recommendations/guidance on this will be much appreciated.

Krishnaveni Balakrishnan

Dear Krishnaveni,

The error you are getting sounds similar to what is reported here: Does this solution work for you?

Best regards,