Question on AeroDyn nodal relative wind speed, Vrel

Hi All,

I am running NREL 5MW cases with different setting in its AeroDyn primary file. My desired output are the AoA, Cl, Cd, and Vrel (relative wind speed) at all 9 nodes of the blade.

The wind condition is power-law wind profile at 10 m/s (at the hub height) and 0.14 power-exp.

In the AeroDyn primary file, WakeMod = 1, AFAeroMod = 1, TwePotent = 0. SkewMod is either 1 or 2 (1 stands for uncoupled, 2 stands for Pitt/Peter’s model). All other parameters are default.

In the cases of SkewMoD =1, the B1N9Vrel, B2N9Vrel, B3N9Vrel are constantly zeros throughout the 30 sec. FAST simulation. In other words, it indicates that relative wind speeds at the blade tips are zero. From my understanding of wind turbine aerodynamics, the relative wind speed supposes to be the highest at the tip. Please correct me if I am wrong.

In the cases of SkewMoD =2, the B1N9Vrel, B2N9Vrel, B3N9Vrel are NOT zeros anymore. The values of nodal Vrel gradually increase from the node 1 to node 9 of the blade. The relative wind speeds in other nodes (node 1~8) do not have large changes comparing to the cases of SkewMoD =1.

Therefore, my question is what SkewMoD I should use to have a good result on the rotor aerodynamics for a non-skewed inflow or even a skewed inflow.

If both SkewMod are feasible, is there any way to solve the problem of zero Vrel at the blade tip for the cases of SkewMoD =1?

Dear Daniel,

In AeroDyn v15.03, which is what I’m presuming you are using, AeroDyn forced the axial (a) and tangential (a’) inductions to 1 and -1 at the tip node, respectively, when the Prantl tip-loss model was enabled (TipLoss = True), which is why Vrel equals zero at the tip when SkewMod = 1. The same thing should have also happened with SkewMod = 2, but a bug in AeroDyn v15.03 allowed a and a’ to differ from 1 and -1 at the tip.

The limit that a goes to 1 at the tip follows directly from the Prandtl tip-loss model. However, after further consideration, we decided that a’ should not approach -1 at the tip, but should instead by 0 when the Prandtl tip-loss model is enabled. In the newer version of AeroDyn that has not yet been publicly released: github.com/NWTC/AeroDyn (also discussed here: http://forums.nrel.gov/t/fast-v8-aerodyn-v15-convergence-problems-for-low-speed-high-turbulence/1532/2), among other changes, we fixed the problem with SkewMod = 2 and now force a’ = 0 at the tip when the Prandtl tip-loss model is enabled.

Normally we recommend to use SkewMod = 2 with WakeMod = 1, except for extreme skew angles (much greater than 45 degrees), where SkewMod = 2 is invalid.

Best regards,