FAST v8 & Standalone AeroDyn v15.03 convergence problems for high shear-exp wind profile

Hello All,

I am running Test26.fst with slight modification as the following

  1. Disable ServoDyn and GenDOF set to be false
  2. Steady Wind Conditions with speed 10 mps at 90 m. The PLexp is 0.35.
  3. The AeroDyn Blade file has ZERO curvature (BlCrvAC), sweep (BlSwpAC), and curvature angle (BlCrvANG).
  4. Airfoil aerodynamics model is Steady Mode, with no tower influence. SkewMod is 1 (uncoupled).
  5. All other configuration are set as default in Test26.fst

However, the FAST encounters errors when I tried to run this case. This configuration only works for PLexp < 0.26. Here is the error message,

It seems like the issue is on the AeroDyn Blade input file because the original AeroDyn blade file does NOT have such errors.

I have tried to use the AeroDyn blade file (zero curvature and sweep) on the Standalone AeroDyn v15.03 with the same wind condition. The result converged without any error. The attachment is the AeroDyn blade model I used in FAST (which gave me errors) and the standalone AeroDyn.

NRELOffshrBsline5MW_AeroDyn_blade_M.txt (2.59 KB)

Notes: please change the extension from .txt to .dat

I do not understand why this issue occur since both of them are based BEMT. Why FAST do not converge for wind profiles with high values of PLexp ?

Thank you.

Dear Daniel,

If you disable ServoDyn, you should disable both the generator degree of freedom (DOF) and the nacelle-yaw DOF. You’ve disabled the generator DOF, but didn’t mention the yaw. My guess is you are modeling a free-yaw machine, which may be the source of the problem (i.e. nacelle yaw may be driving an instability).

Regardless, the error regarding “no valid value of phi” has recently been resolved through an algorithmic change to the BEM algorithm of AeroDyn v15, as reported in the following forum topic: http://forums.nrel.gov/t/fast-v8-aerodyn-v15-convergence-problems-for-low-speed-high-turbulence/1532/2.

Best regards,

Hi Jason,

Thank you for your suggestion. I changed the ElastoDyn DoF setting and disable all the DoFs (since my focus is on the aerodynamics). However, the convergence problem still exists for the straight NREL5MW blade FAST simulation.

is this caused by setting SkewMod=1?

I am not sure why changing the NREL5MWblade to straight will causes this issue. Please advise.

Thank you for all your help.

Dear Daniel,

Setting SkewMod to 1 should not cause any problems.

While you may have disabled all structural DOFs in ElastoDyn, you said that you started with Test26, which uses BeamDyn to model the blade structural dynamics. So, my guess is that you still have an aero-elastic solution. Regardless, recompiling FAST using the source code referred to in the forum topic I linked above (http://forums.nrel.gov/t/fast-v8-aerodyn-v15-convergence-problems-for-low-speed-high-turbulence/1532/2) should solve the problem. Alternatively, if you are interested in pure aerodynamic response, without the influence of structural DOFs, I suggest that you use standalone AeroDyn v15.

Best regards,

Hi Jason,

Thank you for the information. I will try to recompile FAST to solve the AeroDyn issue, but I am not very good at this.

I also found that the convergence issue can be solved by setting TanInd to false. However, this may not fully capture aerodynamics of the rotor. I am not sure if this is a good approach. Please advise.

My research area is more focusing on the blade aero-elasticity. This is why I use BeamDyn and disable the structural DoFs.

Thank you.

Dear Daniel,

I’m not sure why tangential induction is effecting the convergence, but I would normally not expect much influence on tangential induction for modern rotors with high tip-speed ratios. Again, I recommend that use the newer version of AeroDyn.

Best regards,