Moment (about z axis) at the tower top and bottom

Hi,

I simulate the turbine under turbulent wind case. The moments about z axis at the tower top and bottom seem to have opposite sign between FAST and Bladed. Is this caused by the coordinate system? The is not found in the other simulations like NWP, EOG.

Thanks
Best regards

Yinping Yang



One possibility is that Bladed and FAST/AeroDyn are not reading the full-field (FF) wind file in the same way. I’m not sure how you are creating the wind file (I assume you are using the same file in both programs), but the “clockwise” flag in the wind “.sum” summary file was added so that the FF grids could be read by FAST/AeroDyn and Bladed in the same way. You can change the “clockwise” flag in TurbSim without affecting FAST/AeroDyn results, but the flag should change Bladed results.

If you are generating the FF file with TurbSim, you should check that the “clockwise” flag in TurbSim’s input file is set correctly. It is also possible that Bladed no longer reads the wind file based on the direction the turbine is rotating–it’s been a long time since Marshall compared the two codes.

Hi Bonnie,

I created the turbulent wind file with TurbSim. Bladed uses also the same .wnd file. It seems that Bladed only needs this .wnd file. FAST needs both .sum and .wnd file. Am I correct? The .HH file is also provided although I donot know if FAST needs it. The clockwise flag is set true. I run FAST with the False flag .wnd file and the results are the same. I will run the Bladed simulation with this new .wnd file of False flag for clockwise.

Thanks for your tips

Yinping Yang

When AeroDyn uses TurbSim’s Bladed-style binary FF wind file (".wnd"), it also needs to read the “.sum” file to determine how to scale the binary data. Bladed does not read this “.sum” file, but you should make sure it uses the same mean wind speed and TI values that are printed in the section “Normalizing Parameters for Binary Data (approximate statistics)” at the bottom of the “.sum” file.

FAST/AeroDyn does not use the HH file if you are using the FF “.wnd” file. You can tell TurbSim not to generate the HH file by setting the WrADHH parameter in the TurbSim input file to false.

Hi,

I changed the clockwise flag to “false” in the input file and generated a new “.wnd” file. This time the results of FAST and Bladed are the same when both programs use this new “.wnd” file. I still do not know why the results are opposite when they use the same “.wnd” file generated with “True” flag in the input file.

Thanks
Best regards

Yinping Yang



You can see the format of the Bladed-style files in Appendix E of the TurbSim User’s Guide (http://wind.nrel.gov/designcodes/preprocessors/turbsim/TurbSim.pdf); notice in particular equation E-5, which shows the lateral position of the grids. If Bladed no longer changes the lateral position based on the direction of turbine rotation, it is essentially seeing a different wind field, even though you use the same “.wnd” file in each code. It appears you have fixed the issue so that FAST and Bladed are now using the same wind field.