Individual Pitch Control

Hi everybody!
I want to implement an external controller which calculates individual pitches as a function of blade loads. How can I configurate the FAST model to accept Individual Pitch Control? By default the pitch control is collective, as we can see if we read record 28. In GH Bladed this is done from the SW interface, but I can not find a way of activating Individual Pitch control in FAST.
Thanks in advance

Dear Jose Manuel Ezquerra,

Near the top of the BladedDLLInterface.f90 source file that comes with FAST is MODULE BladedDLLParameters. This MODULE contains model-specific inputs available in the Bladed code that are not available inputs in FAST. The INTEGER PARAMETER Ptch_Cntrl, specifically, is used to enable collective (Ptch_Cntrl = 0) or individual (Ptch_Cntrl = 1) pitch control (Ptch_Cntrl = 0 is default). The value of Ptch_Cntrl is passed through avrSWAP(28) to the DLL. Simply recompile FAST with Ptch_Cntrl set to 1 in BladedDLLInterface.f90 to enable individual pitch control by the Bladed-style DLL.

I hope that helps.

Best regards,

Hi my friends!
I did the change Jason suggested to do in the BladedDLLInterface source file to use an individual puitch control for a 5MW turbine. I compiled and linked it using INTEL Fortran 9.1 and Visual Studio. The problem that I have is that when I execute the new FAST file pffoduced, an error message is prompted: “Unrecognized binary wind type file”. So, I usedc the debugger and I fdound something wrong in the execution of FFWind.f90 code. At the line 121 of FFWind.F90, at the CASE instruction, the variable that controls the CASE instruction (DumInt) has a strange value, DumInt=327581. I haven’t got a clue why this happens. Can anybody help me?
Thanks in advance and have a ghood day.
Jose Manuel

PD: Jason and Bonnie, congratulations!

Hi,

I can think of a few reasons this error might appear:
-Perhaps the binary FF file is corrupted or is not really a binary file.
-Perhaps the binary file was generated on a Unix system and you are using it on a PC (or vice versa).
-Perhaps the FAST executable was compiled with different compilation flags than we use.
-Perhaps the FAST executable was compiled with the wrong Sys*.f90 file from the NWTC Subroutine Library, or your compiler needs a different Sys*.f90 file than is included in the NWTC Subroutine Library archive.
If you were able to open the wind file with a version of FAST you didn’t compile, that eliminates the first 2 options. The issue then comes down to how you compiled your code. Something is likely causing the binary file to be opened incorrectly so the code does not read the first number from the file correctly. A similar problem is discussed here: http://forums.nrel.gov/t/fast-compiled-with-g95-reading-full-field-wind/215/1 (where the OPEN command in OpenBinInpFile() had to be changed for the GNU compiler).

If you get the error when you compile with SysIVF.f90 (and use the compile options in the FAST documentation), you may have to modify subroutine OpenBinInpFile(). I have not compiled with IVF 9.1, so I’m not sure what issues it may have.