FAST

Dear Jonkman,
I have a question that suppose we are running a simulation for 500 sec and we want to change some data in between simulation then how can we do that, suppose we have to change the blade mass properties at 100 sec .then how can we do that?

Dear Anuj,

It is not possible in FAST to change the blade mass in the middle of a simulation. I’m not sure why one would want to anyway.

Best regards,

I am asking this because i read one paper of Kim and Yae in that paper they are doing the analysis for a partially broken blades and they are doing like that i.e after 100 sec of simulation they are changing the blade properties .

Dear Anuj,

Kim and Bae have also made their own customizations to FAST. It is not possible in the standard version of FAST to change the blade mass in the middle of a simulation.

Best regards,

Dear sir,
I am trying to simulate the “NRELOffshrBsline5MW_OC3_Hywind” model that I downloaded from Jason Jonkman’s NRELOffshrBsline5MW public directory.First of all the wind file is not given in the directory for 5MW so I have taken 1.5MW wind file and did appropriate changes such that hub height =90m, wind speed =11 m/s,AnalysisTime =600, GridHeight=155 , GridWidth=155 and then i have simulate windfile in cmd prompt as “turbsim windfile.inp”.Then it is terminating normally and generating wnd file which is further used in AERODYN while simulating the FAST fst file.

but when i start simulating the fst file it is giving error as:
[b]small angle assumption violated in SUBROUTINE smllRotTrans<> due to large blade deflection

Blade element #1 is supersonic

Grid in y direction is small

error getting velocity in aerodyn[/b]
I have made changes in grid width and grid height several times but it is not terminating. Please guide me if am doing anything wrong or there is another way to complie this 5MW Files instead of compiling in cmd prompt.How we can remove this “grid error and error getting velocity in aerodyn”.

kindly suggest me

with regards
Neeraj.Kumar

Dear Neeraj,

We purposely left out the wind files from the NREL 5-MW model archives because adequately sized wind files for the NREL 5-MW are typically very large. See the last four posts on the forum topic linked here for an explanation and for a link to where you can download a TurbSim input file for this turbine: http://forums.nrel.gov/t/updated-nwtc-design-codes-available-on-our-web-site/237/1.

Warnings regarding a “small angle approximation violation,” warnings regarding “supersonic blades,” a simulation crash, or very large deflections that occur in the time series near the start of a simulation are good signs of a numerical instability. Without knowing more about your simulation settings, it’s hard to know that what the problem is. But the NREL 5-MW turbine models should not have these problems, unless you’ve customized the model in some unphysical way. See the following forum topic for more information: http://forums.nrel.gov/t/nrel-5mw-controls-dll-interface/183/1.

I don’t understand your question about compiling. Input files don’t need compiling and you don’t need to recompile FAST unless you need to make changes to the source code.

Best regards,

dear sir
Thanks for your reply
actually i was trying to simulate .fst file in command prompt and i havn’t made any changes in source code, I just used sample file for wind with the following changes only :

511347 RandSeed1
RanLux RandSeed2

7 NumGrid_Z
7 NumGrid_Y
0.05 TimeStep
600.0 AnalysisTime
600.0 UsableTime
90.2876 HubHt
165.0 GridHeight
165.0 GridWidth
0 VFlowAng
0 HFlowAng

  1.            RefHt      
    

8.0 URef
then turbsim terminated normally but when running .fst file with all the other inputs (aerodyn,tower,blade,platform,spd_trq,pith control)
then also it is giving error like “Rzero = 1.0423 must be smaller than 1” and “blade deflection large”.
sorry to ask you for the basics but i am a new user to FAST, so suggest me sir.

Dear Neeraj,

I don’t think the problem is with turbulent wind data file.

In your e-mail you refer to “spd_trq”, which is only used by Kirk Pierce’s sample variable-speed controller, UserVSCont_KP.f90. However, as explained in my Apr 06, 2011 post in this forum topic (above), the NREL 5-MW turbine models do not use this controller. To use Kirk Pierce’s controller, you must set GBRatio to unity. I suspect you made these changes, which are causing the model to go numerically unstable. Change GBRatio back to 97.0 and use the executable of FAST provided with the OC3-Hywind model and your simulation should run fine.

Best regards,

Dear sir
Thanks for your suggestion but again when i run the simulation with GBratio 97 it is giving error as :
stack trace terminated abnormally .
Induction factor calculation did not converge.

Dear Neeraj,

I don’t know what is causing your problem. Please download the original OC3-Hywind model files (include FAST input files, DLL controller, and FAST executable) from my website and run it without modification using the TurbSim wind data file that you’ve generated.

Best regards,

Dear Jonkman,

Thank you very much for your constant help in the forum.

I have run FAST 8 for offshore NREL 5MW Jackets and monopiles. I need to validate my results with verified responses (Displacements and forces in top of tower and transition piece or forces in mudline) in time history. I read NREL reports of this turbine and also this forum, but I was not able to find this kind of responses . I just found electricity power plots vs wind speed and they are very electrical. Could you please introduce a reference that has this kind of responses (Time history of structural responses for NREL 5MW Offshore jackets and monopile).

Thank you in advance for your reply.

Best Regard,

Arash,

Dear Arash,

There are a few time-histories from the FAST v8 models of the OC3-monopile and OC4-jacket published in our recent AIAA SciTech 2015 paper focused on the verification of the new fixed-bottom offshore modeling capability in FAST v8. You can find that paper here: nrel.gov/docs/fy15osti/63067.pdf.

Best regards,

Dear Jonkman,

Thank you very much for your help.

I tried to validate my jacket 5MW result with the result in the paper you recommended. But the results are not the same. I downloaded the Test21.fst sample and for the 4.3b loadcase (Without wind load, with regular wave conditions)

The changes I made to the sample file:

  1. I changed air density to 0 in Aerodyn input file to make wind condition zero
  2. In Hydrodyn input file, I changed Wavemod to 1 (regular) with H=8 m and T=10s
    3)In Elastodyn input file, I changed Initial rotor speed to 0

and I ran FAST. However the results seem more fluctuating than that of the paper. The range seems OK but my results have more frequencies.

Could you please take a look at the graphs and give your opinion about the discrepancy.

Thank you very much for your time,

Best Regards,

Arash,

Dear Arash,

For load case 4.3b of the OC4-jacket simulation, I would suggest:

FAST

  • CompAero = 0 - Disable AeroDyn instead of setting the air density to zero
  • CompServo = 0 - Disable ServoDyn

ElastoDyn - Disable all tower-top DOFs

  • FlapDOF1 = False
  • FlapDOF1 = False
  • EdgeDOF = False
  • DrTrDOF = False
  • GenDOF = False
  • YawDOF = False

(I agree with setting WaveMod = 1 in HydroDyn and RotSpeed = 0 in ElastoDyn.)

Regardless, the basic problem I see with your solution is that you haven’t run it long enough for the start-up transients to die out. Simply run the simulation longer and the start-up transients will dissipate. If you remove the first 30-60 s (or whatever is needed) from your post-processing, your results should match those of the paper.

Best regards,

Dear Jason,

I am running the NREL 5MW landbased turbine in DLC6.2 of IEC61400-1 in FAST v.7 with a loss of connection to the electrical grid so that the yawing system and blade pitch system is not active. I assume the wind turbine to be class 1 and the EWM then yields a hub height wind speed of 1,4*50 m/s = 70 m/s. My intention is to examine wind directions in the range (0;180 deg). Whenever the yaw error in the wind file is larger than 0, I get an error of “small angle assumption violated in SUBROUTINE SmllRotTrans() due to a large blade deflection. The solution may be inaccurate. Simulation continuing, but future warnings will be suppressed”.

I have read the other posts concerning the same problem and tried changing the integration time step to 0,003, but the problem persists. Then I have tried lowering the wind speed and the problem disappears if the wind speed is maximum 59 m/s and occurs at 60 m/s or more.

I have set YCmode to 0, pcmode to 0, vscontrl to 0 and pitched all 3 blades to 90 degrees. I am mainly interested in the tower loads. I have tried disabling the blade dofs, and then the problem disappears, but can I then trust the tower loads that I get?

Dear Jacob,

I’m aware of a potential blade-edgewise and tower side-to-side-mode instability (negative damping) that can occur when the NREL 5-MW turbine is parked with all blades feathered to 90 degrees in high winds with yaw errors between 20-40 degrees. You can read about this in Section 6.2.1 of my PhD thesis-turned NREL report: onlinelibrary.wiley.com/doi/10.1002/we.442/pdf.

I’ve been able to verify this with simpler models, such as with steady uniform wind or as a linearized FAST model. I have talked to other modelers and heard that this problem has been seen in many different turbines and with different aero-elastic software. The current belief is that the instability would likely not occur in the physical world and that the aero-elastic software only predict a problem due to simplifications in how the software treat the dynamics of deep stall. My understanding is that the industry’s current approach to dealing with this problem is to either (1) bypass it by choosing yaw errors that don’t result in the instability or (2) increase the structural damping in the blade edge / tower side-to-side mode until the instability goes away.

I hope that helps.

Best regards,

Dear Jonkman,

I am doing Simulation for the 10MW Spar-buoy Wind Turbine system.I am doing load case power production(DLC:1.3, IEC turbulence type-ETM).

Unfortunately at 9 m/s wind speed(Hs-0.95,Tp-3.33) I am getting error “small angle assumption” for that I have upload the picture as below.
I have read all the post regarding “small angle assumption”. so far this error is concern,the problem is numerical instability in my model.So I have seen in many post that solved only by decreasing the time steps but for my model I can not decrease the time step more than 0.00125. If I use 0.0000125 then I am getting another error I have uploaded the picture of that error as below.

I have tried with grid size from 88 till 3030 ( timestep 0.00125s) to run the simulation.(Most of the time simulation aborting between 200 to 300 s) Also I have tried with more than 0.00125(time step) but simulation aborting.My last simulation at 7m/s wind speed completed with grid 8*8 and time step was 0.00125 s.

My question is that these error is due to numerical in stability so I need to try with very small time steps Am I right?? If is there any other input parameters need to change in TurbSim input file then please let me know. and can you please tell me what should I do to use the 0.000001 s time steps.
I am using OpenfAST-V1.0.0(Compile info-architecture :64bit, precision: single)

I hope you can clearly understand my problem and guide me as soon as possible.

thank you so much for your help and support.

Best regards
Mitesh Ramani


Dear Mitesh,

There is no reason to set the TurbSim and FAST / OpenFAST time steps identically.

There is usually no need to run TurbSim with a time step smaller than 0.05 s, which will generate turbulence up to 10 Hz.

Your OpenFAST model is clearly going numerically unstable, but you haven’t provided me with any information to guess as to why. You could try a time step smaller than 0.00125 s, but that is already quite small.

Best regards,

Dear jason,

Thank you so much for you time and you support.

I can understand that There is no reason to set the TurbSim and OpenFAST time steps identically.That is why I am using OpenFAST time steps 0.0125(s) and only changing the time steps in my TurbSim input file.

Thank you for information that,there is usually no need to run TurbSim with a time step smaller than 0.05 s.Because it will generate turbulence up to 10 Hz.

As you told me to try time steps smaller than 0.00125 s, so I have tried with 0.000125 s and grid size is 88 but still my Simulation is aborting around 40 s.Also I have tried grid size till 2020. but Its aborting around 300 s most of them.

If I use smaller than 0.000125 s for example 0.00001 then I am getting error like a “Error allocation #some numerical values# MB for the turbulence PSD Array” As I uploaded picture in my last post.

I have uploaded my turbSim file ,HydroDyna and ElastoDyn file as below kindly find it.Also I would like to ask that there would be any other input parameters responsible for this numerical unstable model.

I hope you will help me out as soon as possible.

I really appreciate for your valuable time and your support.

Best Regards
Mitesh Ramani
HydroDyn.rtf (18.3 KB)
ElastoDyn.rtf (27.1 KB)
TurbSim.rtf (6.14 KB)

Dear Mitesh,

You misunderstood me. The time step in TurbSim should be set to 0.05 s. You may need to drop the time step in OpenFAST less than 0.0125 s.

Best regards,