FAST V8 Warning and Error

Hello Sir/Madam,

I am using FAST V8. Using Test18.fst, onshore turbine. I did not change anything in FAST code apart from wind velocity URef. I did change in TurbSim.inp. The changes in *.inp files are 1) HubHt = 90, 2) GridHeight 130, 3) GridWidth 130, 4)RefHt 90, 5) URef 25m/s.

I assumed that HubHt and RefHt both 90 and assumed 25 m/s wind at hub height.

I get warning and FATAL error.

Warning: Turning off Unsteady Aerodynamic because C_nalpha is 0 BladeNode = 1 Blade =1. This warning is repeated for 4 times ( for 4 BladeNode) and for each blade ( total blades are 3).

FATAL Error: The program goes ahead and runs FF file *.bts. The program says grid is too small in Z Direction. (height z = 0 is below the grid and no tower points are defined.

I have 63 m tip radius and providing gird size 130. So grid is sufficient for 90 m hub height tower. I tried to apply load slowly by changing DT in *.fst to 0.002 but still I get error and warning as above.

I am not sure if warning is leading to fatal error. Or these are two separate issues with my simulation.

I went onto forum and tried to change BlPitch to 17.5 for initial condition. But even then the warning and error continues. I think the tower is stiff enough for 25 m/s wind. I ran version 6 and I did not get this error or warning.

I request your help in this regard. I appreciate your precious time and efforts.

Thanks
Atul.Patil
(Florida State University)

Dear Atul,

I cut and pasted below you entry from the other topic you opened regarding this question and subsequently deleted that topic. Please don’t open up multiple topics for the same question.

To answer your question, the error message you are receiving has nothing to do with the warnings you are receiving regarding the disabling of unsteady aerodynamics. The latter warnings are always issued for airfoils that have C_nalpha set to zero. You are receiving the fatal error because your model includes tower analysis nodes in AeroDyn that extend down to the ground, but you haven’t created a wind file that has data that extend down to ground. To generate such data, you should set WrADTWR to True in the TurbSim input file and regenerate your wind data (including data that extends along the tower down to the ground).

Best regards,

Thanks Dr. Jonkman
Now I am facing new warning that large blade deflection. I tried to apply the load slowly by reducing DT to 0.00125.

Please see below the cmd window output

Readin g a 14x14 grid (160 m wide, 17.5 m to 162.5 m above ground) with a characteristic wind speed of 25 m/s. This full-field file was generated by TurbSim (v2.00.07a-bjj, 14-Jun-2016) on 28-Nov-2016 at 17:03:30.

Processed 12000 time steps of 20-Hz full-field data (period of 600 seconds).

Running ServoDyn (v1.06.00a-bjj, 26-Jul-2016).

Running ServoDyn Interface for Bladed Controllers (using Intel Visual Fortran for Windows, 14-Oct-2015).
Timestep: 0 of 600 seconds.

FAST_Solution0:CalcOutputs_And_SolveForInputs:SolveOption2:SrvD_CalcOutput:Running with torque
and pitch control of the NREL offshore 5MW baseline wind turbine from DISCON.dll as written by J.
Jonkman of NREL/NWTC for use in the IEA Annex XXIII OC3 studies.

Warning: Turning off Unsteady Aerodynamics due to high angle-of-attack. BladeNode = 5, Blade = 2

FAST_Solution:FAST_AdvanceStates:ED_ABM4:ED_CalcContStateDeriv:SetCoordSy:Small angle assumption
violated in SUBROUTINE SmllRotTrans() due to a large blade deflection (ElastoDyn SetCoordSy). The
solution may be inaccurate. Simulation continuing, but future warnings from SmllRotTrans() will be suppressed.
Additional debugging message from SUBROUTINE SmllRotTrans(): 0.5175 s
Timestep: 25 of 600 seconds. Estimated final completion at 18:12:23.

If you get some time, I would like to request your help.

Thanks
Atul.Patil
Florida State University

Dear Atul,

My guess is that you are getting large blade deflections during the start-up transient because you haven’t initialized the rotor speed and/or the blade-pitch angles properly for the given wind speed. See the following forum topic for my recommendations on setting initial conditions for FAST simulations: http://forums.nrel.gov/t/initial-conditions-for-tower-and-rotor/609/1.

Best regards,

Hello Dr. Jonkman,

Thanks. it’s working. I appreciate your precious time and efforts.

Atul.Patil
Florida State University

Dear all

I am currently trying to interface the 10MW openfast semi-sub model with my drivetrain model
My drivetrain model is based on the direct-drive configuration and as such I changed the gearbox ratio to 1 (as the DTU model uses a medium-speed gearbox)
I also am controlling the drivetrain based on the K*omega^2 control technique (where K = Kopt and is constant & omega represents the low speed shaft rotor speed)
I changed the servodyn file so that it will use my drivetrain model and also my pitch controller
Currently I am testing it with a constant wind speed and below rated conditions (8m/s where the pitch has a steady-state value of 0 degrees)

When I try to run this simulation I receive the following error message
"Error using Fullscale10MWtwolevelconverter (line 121)
Error reported by S-function ‘FAST_SFunc’ in ‘AdGentest/FAST Nonlinear Wind Turbine/S-Function’:
FAST_Solution:FAST_AdvanceStates:ED_ABM4:ED_CalcContStateDeriv:SetCoordSy:Small angle assumption violated in SUBROUTINE SmllRotTrans() due to a large blade deflection (ElastoDyn SetCoordSy). The solution may be inaccurate. Simulation continuing, but future warnings from SmllRotTrans() will be suppressed.
Additional debugging message from SUBROUTINE SmllRotTrans(): 1.50000E-02 s
FAST_Solution:FAST_AdvanceStates: MD_UpdateStates: NaN state detected.
"
Also I noticed a file labelled “controller_input”, could that have something to do with the error I have encountered?

Any feedback provided will be helpful
Thank you very much
Kind regards,
Cameron

Dear Cameron,

It sounds like your model is going numerically unstable very quickly.

When you decreased gearbox ratio (GBRatio) to unity, did you also increase the generator inertia (GenIner) accordingly? GenIner scales with GBRatio^2. Without increasing GenIner along with the decrease in GBRatio, you’d introduce a very high natural frequency in the drivetrain-torsion DOF that would require a much smaller time step and/or numerical instability problems if the time step has not been reduced.

Best regards,

Hi Jason,

Thanks for the response
The system is stable now after considering your feedback
Kind regards,
Cameron