FAST 'supersonic' warning followed by enourmous AoA!

I am having difficulty getting FAST to run with my inputs. The turbine I am simulating only has a diameter of 0.8m, could this be part of the problem?

How is FAST generating such large AoA? I guess this is causing the overall problem, I would have assumed that the AoA would be constrained between -180 and +180 degrees?

Thanks,

Pascal

Dear Pascal,

Warnings regarding a “small angle approximation violation,” warnings regarding “supersonic blades,” a simulation crash, or very large deflections that occur in the time series near the start of a simulation are good signs of a numerical instability. Without knowing more about your simulation settings, it’s hard to know that what the problem is.

If you believe your structural mass/stiffness properties are all set properly, my guess is that the integrator time steps are not set properly, which is what is leading to the numerical instability. See my post dated Nov 4, 2010 in the forum topic found here for rules of thumb on how to choose proper time steps: http://forums.nrel.gov/t/error-in-fast-working-in-adams/298/1.

Best regards,

Thanks for this advice, I had seen the previous post but it did not help me at the time becuase I discovered a further error in the blade geometry input file. The time steps I have to use to prevent a crash are tiny though (0.00001s), probably due to the nature of the small turbine I am using (0.8m diameter) requiring a high resolution. Hopefully this does not introduce too many problems other than long run times.

Dear Pascal,

Based on the rule of thumb for choosing time steps, a structural time step of 0.00001 s implies that the highest frequency in your model is 10000 Hz. What mode in your FAST model has such a frequency? This frequency seems unrealistically high for a tower or blade bending mode with a rotor diameter of 0.8 m. Are you sure you’ve specified the tower and/or blade mass, stiffness, and/or mode shapes realistically in your model?

Best regards,

Dear Jason,

This may explain some of the strange results then! Essentially, I was hoping to simulate a rigid blade so I simply left the stiffness/mode shapes as per the example file I used (AWT test file). Since these values will be significantly higher than in reality I assumed (obviously incorrectly) that this would simply mean no bending.

What you you advise? Can I use a setting to simulate a rigid blade (I am after the time series root blade bending)? The experimental model I use has solid aluminium blades with very little bending. If I have to include stiffness/mode shapes precisely how can I do this without significant extra work (i.e. i do not really want to have to undertake any FEA if possible)?

Thanks in advance,

Pascal

Dear Pascal,

You can model a rigid blade in FAST by disabling the blade-bending DOFs. That is, set FlapDOF1, FlapDOF2, and EdgeDOF all to False in the FAST primary input file. FAST will still allow you to output blade loads (such as root bending moments) in this case. You should only enable DOFs for components that are specified correctly (i.e., for components whose mass, stiffness, and mode shapes are correct).

Best regards,

Dear Jason,

I had already disabled the blade DOFs but had stupidly left the generator model enabled. After disabling this and correcting blade mass density data the blade root bending moments are what I was expecting.

Thanks for your help with FAST (and Bonnie’s). Without this forum I would have never got the program to run successfully due to its many complexities! Maybe a little more detail is required in the manual to help people create their own input FF files, this took me some time and guesswork to complete.

Thanks again,

Pascal