FAST: blade flexibility troubleshooting

Hello,

I am having some problems simulating a turbine with flexible blades and I was wondering if there is a simple fix for it…

When I am simulating the turbine with blade flexibility turned off, the turbine seems to behave well. When I turn the blade flexibility on, the program crashes right from the start (the error message informs me that there is a large blade deflection).

I have gone through my input values a number of times and can’t seem to spot anything… I have made the blades 10, 100, 1000 times stiffer than they are and I am still getting the same problem. (I am 100% sure its not a stiffness issue)

I was hopping that this has some simple solution, since I had the same problem with tower flexibility and the solution was quite simple: i had set TwrNodes = 1 , but in reality I had 2 stations defining the tower. When I fixed this, the simulations run without any problem…

Can anyone suggest any possible causes?

Thanks for reading this…
Thanos.

Thanos,

Since increasing the blade stiffness did not fix your problem, I suspect the problem lies with the time step, DT, and not the stiffness. If a structural time step is chosen too large for the given natural frequencies you are trying to capture in the structural dynamic response, this may trigger the “large blade deflection” warning you are seeing because the solution is numerically unstable.

I always recommend that users try different values of DT and pick the largest possible one that gives results that don’t depend on the choice of DT. The required time step in a FAST model is intrinsically related to the system frequencies being modeled. For the time-marching integration scheme that is implemented in FAST (a 4th order Adams-Bashforth-Adams-Moulton predictor-corrector), a good rule-of-thumb that I have discovered is that the time step should be set less than or equal to one over ten times the highest full system natural frequency. That is, in equation form:

DT <= 1 / ( 10 * highest full system natural frequency in Hz )

The full system natural frequencies can be found by running a FAST linearization analysis (AnalMode = 2) about the initial conditions. See the Linearization chapter of the FAST User’s Guide for more information.

Since turning off the blade DOFs fixed the problem, I suspect it is the blade natural frequencies that are too large (and increasing the stiffness only made the problem worse). Simply reducing the time step (based on the rule-of-thumb above) should fix the problem. Or, if the blade mass and stiffness distributions you are using are “made-up”, they may have been chosen poorly, resulting in unrealistically high blade frequencies–in which case, the time step may be fine, but the mass and stiffness distributions will need to be changed.

With regards to to the tower, input TwrNodes is completely independent of the stations that define the tower sectional data. Input TwrNodes determines the number of analysis nodes used for the integration of the elastic and inertia forces of the tower. In contrast, input NTwInpSt defines the number of stations used to define the tower sectional data in the tower input file. For example, if the tower is uniform, only one section needs be defined, so you may set NTwInpSt to 1. However, increasing TwrNodes always results in a more accurate integration of the elastic and inertia forces, at the expense of slowing down the simulation. Typically, TwrNodes should be chosen in the range of 10-20. FAST will always interpolate the table of input sectional data (defined by NTwInpSt) to the locations of the analysis nodes (defined by TwrNodes).

Best regards,

Jason,

I decreased the integration timestep and the simulation run without any problem. Thanks for you help and the explanation. :smiley:

Regards,
Thanos

Dear Jason,
I want to observe the deformation of blades under different wind speeds and turbulence levels, which requires the setting of blades flexibility. I checked “…ElastoDyn.dat”,"…AeroDyn15.dat" and “BeamDyn.dat”, but I didn’t find it. In which file should this function be set? Thank you !

Best regards,
Liye

Dear @Liye.Zhao,

Blade flexibility can be modeled in either ElastoDyn or BeamDyn. ElastoDyn can be used if the deflections are expected to be moderate, if the blades are initially straight (rather than prebent) and only bending flexibility is important. BeamDyn can should be used for large deflections, blades with prebend, and where torsion and other flexibilities are important.

Best regards,

1 Like

Dear Jason,
Thank you for your reply! I’m new to this knowledge and don’t know how to do it, could you please give me some examples to learn how to modify. About the two situations you mentioned.

Best regards,

Dear @Liye.Zhao,

I don’t really understand your question. Are you asking how to define blade flexibility in ElastoDyn or BeamDyn? If so, which wind turbine are you trying to model and does one of the examples provided in the OpenFAST r-test meet your needs? Or are you asking which output parameter should be examined?

If you are simply asking how to run OpenFAST, I would review the provided OpenFAST documentation before posting questions.

Best regards,

Dear Jason,
I’m very sorry that I didn’t express the question I want to ask, but now I’ve figured out what’s going on. Thank you!

Best regards,
Liye