FAST.Farm

Dear Dr.Jonkman,

I downloaded the source code in Bonnie’s reply and compiled it.When I simulated it using the newly generated FAST.Farm_x64_OMP.exe, the error in the picture occurred. And OpenMP is still No.


I don’t know what the problem is. Is there something wrong with some configuration during my compilation?

Best Regards,

Dear @Jian.Zhang,

You had e-mailed something similar previously; is that correct? The problem still seems to be driven by a high skew angle, which I’m a bit surprised by.

Regarding your new results, I also see large platform-roll motion (PtfmRDyi). Are you simulating the NREL 5-MW baseline wind turbine atop the OC4-DeepCwind semisubmersible? I wouldn’t expect this much roll motion for this FOWT.

Also, is the following correct?

WvHighCoff 1.570796→0

This would imply that the waves are fully filtered out; is that true?

I also see that the issues exists for WT1, which is presumably upstream of the other. This means you should be able to see similar issues when simulating with standalone OpenFAST, uncoupled from OpenFAST. I would debug there before switching back to FAST.Farm.

Best regards,

Dear @RuoNan.Zhu,

I’m not sure what source code you are referring to, but it does not look like you are running a version of FAST.Farm compiled with OpenMP. Regarding the error you are receiving, this looks to be caused by the use of an input file that is not compatible with the version of FAST.Farm you are running. As with any input file processing error, I would enable the Echo option to debug.

Best regards,

Dear Dr.Jason,

I have now successfully made OpenMP Yes, due to the previous failure caused by the wrong configuration selection of the platform at compile time. But the second problem remains.

Best regards,

Dear @Jason.Jonkman

For the “WvHighCoff 1.570796→0”, I consider I have a typo, and I set the “WvHighCoff 1.570796→500”.

Maybe I should give more description about my simulation cases. With the synthetic wind inflow generated by TurbSim, the codes run well whether for OC4-DeepCwind semisubmersible and OC3 Spar platforms. I should say the given examples performed well with FAST.Farm.

The error information appeared in the cases considering the wake-added turbulence (which might be caused by the blade tip or root vortex shedding) with my recompiled executable program. The case for OC3 Spar performed well, but unfortunately, the failure appeared in the OC4-DeepCwind semisubmersible case, as shown before, with the information of the high-thrust and low TSR.

I uploaded the cases into Google disk, which might be slightly large due to the big tempo-spatial wind field. If possible, could you have a quick look, as I have no idea after a long-time debug process?
:rofl: :sweat_smile:

https://drive.google.com/drive/folders/1vgssrUM80FZoAt_vLIWp1d8pf1pNKuiS?usp=sharing

Thank you very much

Best regards,

Dear @RuoNan.Zhu,

Again, regarding the error you are receiving, this looks to be caused by the use of an input file that is not compatible with the version of FAST.Farm you are running. As with any input file processing error, I would enable the Echo option to debug.

Best regards,

Dear @Jian.Zhang,

I don’t seem to have access to your Google drive. But it sounds like the problem may be related to the wake added turbulence branch of FAST.Farm that you are using. This branch is not supported by NREL, so, I’m not sure how to help; I would suggest reaching out to Matthias Kretschmer.

FYI: We are working at NREL to add a wake added turbulence into FAST.Farm, and have a used Matthias Kretschmer’s work as a starting point, but we are changing the implementation a bit to make it a bit easier to use.

Best regards,

Dear Dr. Jonkman,

Thank you for your reminder. I will turn to Matthias Kretschmer for help, and even so, I attached the examples in the following links.

https://drive.google.com/drive/folders/1vgssrUM80FZoAt_vLIWp1d8pf1pNKuiS?usp=share_link

The confusing aspect is that I could run the Spar and TLP case with the introduction of wake-added turbulence; however, it does not apply to the Semisubmersible one. I know you are currently busy, so maybe have a quick look if allowed. If not, ignore it—many thanks.

Best regards,