BModes: Eigensolution Failed, problem not +VE semi-definite

Hi everybody,
I am using BModes to compute the natural frequencies of a blade, and I get the following message, after the reassuring
“all parameters checked: ok”

Eigensolution Failed, problem not +VE semi-definite

this happens for any value of the rpm, and I cannot think of any other modifications, since the input data used for the section properties are actually produced by PreComp.

I already sent an E-Mail with more details and the input files as attachment to Gunjit Bir.

I would be grateful for any hint.

Thanks a lot
and best regards from Italy
Claudio

Hi,
I have a clue on this. I’m able to reproduce the very same error. Then augmenting stiffnesses values manually make it to disappear and obtain some results, erroneous of course :slight_smile:

I suppose this error is somewhat related to the values calculated by PreComp (please see the following post [forums.nrel.gov/t/precomp-oddity/173/1))

cheers
Stefano

Hello there,

Sorry to resurrect an old topic, but I am currently running into this exact error message very frequently when using BModes. Has there been any new findings on how to avoid or correct this error?

I have tried to manually change some of the structural properties in my BModes input file (say, near the blade root or tip where I suspect that values look “suspicious”), but I have not been able to solve the “Eigensolution Failed, problem not +VE semi-definite” error or determine exactly what causes it.

Can you give some explanation on “how” you augmented the stiffness values? Is this error caused by erroneous stiffness values, or perhaps something else that is input into BModes?

Thanks and Kind Regards,
Danny Sale
University of Washington