BEM is automatically turned off

Dear all,

I simulated an onshore wind turbine with steady wind (14 m/s), the rotor has no initial RotSpeed, and WakeMode =1 in Aerodyn15. I found this warning message:

The BEM solution is being turned off due to low TSR.  (TSR = 0)

I guess the reason is that my rotor starts to rotate from 0 rpm, so tip speed ratio (TSR) = 0. Thus the initial condition in my model is more like a parking condition.
And wake model is for working condition (i.e. rotating rotor), thus it seems reasonable that BEM is automatically turned off by the code.

  1. Howerver, as I set WakeMode =1, and my rotor will rotate after enough time, I want to know when BEM will be truned on? TSR larger than some value?

  2. Is there a maximum value of TSR beyond which BEM is not accurate/suitable any more?
    Is there a range of TSR within which wind turbine can work normally?
    As I simulated the case without any control, I find that TSR can reach 16. So I doubt whether the rotor aerodynamic force is reasonable.


Dear @Ran.Tu,

Regarding your first question, yes, as of OpenFAST v2.5 and newer, BEM is disabled when the TSR is below unity, enabled when TSR is above two, and blended between these limits. See the following PR for details: Updates to AeroDyn by bjonkman · Pull Request #538 · OpenFAST/openfast · GitHub.

Regarding your second question, BEM is not disabled at high TSR. However, there are various corrections, e.g,. limits on induction and a high thrust correction that are employed to minimize unreasonable aerodynamic solutions.

Best regards,