AeroDyn15 & ElastoDyn in OpenFast

Is it possible to run AeroDyn, excluding the tower influence on the fluid local to the blade nodes, and the tower drag and similarly for ElastoDyn.
In other word just considering the rotor. If it is possible can someone provide an example of XXXXX_Aerodyn.dat and XXXXX_ElastoDyn.dat

Thanks in advance.

Davide

Dear David,

Yes.

In AeroDyn, set TwrPotent = 0 and TwrShadow = False to disable the tower influence and TwrAero = False to disable tower aerodynamic loads.

To ensure the support structure is rigid in ElastoDyn, disable all platform DOFs (PtfmSgDOF = False, etc. for all 6 platform DOFs) and tower DOFs (TwFADOF1 = False, etc. for all 4 tower DOFs).

Best regards,

Thanks a lot for your prompt reply.

Error:

I do not understand why the code looking at some keywords that should not be in the coordinates file (looking at the IEA_LB_RWT-AeroAcoustics example)

Does anyone know what the above error can be related to?

Thanks in advance.

Dear Davide,

Did you change this aeroacoustics example in some way? I can’t find AF00od1_Coords.txt in the IEA_LB_RWT-AeroAcoustics example.

The BL_file keyword is needed in the airfoil data file when aeroacoustics is enabled in AeroDyn (CompAA = True). Are you trying to run a simulation with aeroacoustics enabled?

Best regards,

I have just changed the name of the airfoil coordinates file.
Using the same name convention the error is the same:

Yes I am trying to run a simulation with aeroacoustics enabled.
I do not understand why the code is looking for BL_File and NumTabs in the coordinates file.

Regards,
Davide

Dear Davide,

It appears that AeroDyn thinks AF00_Coords.txt is the airfoil data file, not the airfoil shape file. Have you changed the names of the airfoil data files in the AeroDyn primary input file (AFNames) to point to AF00_Coords.txt instead of the actual airfoil data file, e.g. RotorSE_FAST_IEA_landBased_RWT_AeroDyn15_Polar_00.dat?

Best regards,

Hi,

In the AeroDyn Primary file I point to the Polar_OX.dat files and inside the polar files I point to the coordinates files:

@“AF00_Coords.txt” NumCoords ! The number of coordinates in the airfoil shape file. Set to zero if coordinates not included.
AF00_BL.txt BL_file ! The file name including the boundary layer characteristics of the profile. Ignored if the aeroacoustic module is not called.
1 NumTabs ! Number of airfoil tables in this file. Each table must have lines for Re and Ctrl.

following the “IEA_LB_RWT-AeroAcoustics” example.

Is that not the correct way?

Thanks again and Regards,
Davide

Hello Davide,
please make sure that the openfast version that you are calling is 2.5.0. When you call OF from the terminal, this should appear on screen
If OF is not 2.5.0, please shift to OF 2.5.0, the latest release
If OF is 2.5.0, please make sure that you are calling this OF model github.com/OpenFAST/r-test/tree … oAcoustics
This must run successfully
Once this runs, try introducing your changes one by one and see when OF breaks.
Another good test is to try turning off the BLMod flag in the aeroacoustic module
github.com/OpenFAST/r-test/blob … ut.dat#L14
Good luck!
Regards,
Pietro

Hi Pietro,

I am using OF 2.5.0

But still I have the same issue.

Really do not know what the problem is

Best Regards,
Davide

Dear Davide,

It still looks to me that AeroDyn thinks AF00_Coords.txt is the airfoil data file, not the airfoil shape file. Please share your AeroDyn, airfoil data, and shape files.

Best regards,

Dear Jason,

I can attach them as txt files only.

But I am allowed to upload just the coordinates file, even if I changed the other two files from dat to txt file.

Thanks and Regards,

Davide
AF00_Coords.txt (11.6 KB)

Dear Davide,

I don’t think the problem is with the airfoil shape file. I think the problem is either in the AeroDyn primary or airfoil data. Please share these files another way.

Best regards,

Dear Davide,

I received your e-mail. Overall, the files you sent look OK to me, except I see one issue. You have set InclUAdata in the airfoil data file to False, but you still include the 30 UA parameters in the file. Does setting InclUAdata = True solve your problem?

Best regards,

Hi Jason,

I want InclUAdata = False

Should I remove the lines from 18 to 49?

Regards,
Davide

HI,

I have tried to set up InclUAdata = True

but this does not resolve the problem

Regards,
Davide

Yes.

Hi Jason,

I have removed those lines but same error

Davide

Dear David,

Did you remove update all of 10 your airfoil data files?

Best regards,

Hi Jason
Yes I did, but always the same error

Best Regards,
Davide

Hi Davide,

We’ll, I’m really not sure then. For the specific model you are running now, all I can suggest is that you compile in debug mode and run the simulation through the debugger. This should help you isolate the error.

Can you run any OpenFAST simulation (e.g., using one of the sample models from the r-test) without error?

Best regards,