Problem running NREL 5MW Test files

hello,

Maybe you can view how much time you set up in your primary input file and wind input file.You must keep your time of simulation larger in wind input file than in the primary input file.if not,the error happened!This my understanding! Maybe it can help you !

Best Regard

Ruiliang.Wang

Here is the time in the wind input file:

--------Turbine/Model Specifications-----------------------
 31            NumGrid_Z       - Vertical grid-point matrix dimension
 31            NumGrid_Y       - Horizontal grid-point matrix dimension
  0.05         TimeStep        - Time step [seconds]
630.0          AnalysisTime    - Length of analysis time series [seconds]
 60.0          UsableTime      - Usable length of output time series [seconds] (program will add GridWidth/MeanHHWS seconds) [bjj: was 630]

and the fst file

------- FAST INPUT FILE --------------------------------------------------------
NREL 5.0 MW Baseline Wind Turbine for Use in Offshore Analysis.
Properties from Dutch Offshore Wind Energy Converter (DOWEC) 6MW Pre-Design (10046_009.pdf) and REpower 5M 5MW (5m_uk.pdf); Compatible with FAST v7.02.
---------------------- SIMULATION CONTROL --------------------------------------
False       Echo        - Echo input data to "echo.out" (flag)
   3        ADAMSPrep   - ADAMS preprocessor mode {1: Run FAST, 2: use FAST as a preprocessor to create an ADAMS model, 3: do both} (switch)
   1        AnalMode    - Analysis mode {1: Run a time-marching simulation, 2: create a periodic linearized model} (switch)
   3        NumBl       - Number of blades (-)
 630.0      TMax        - Total run time (s)
   0.0125   DT          - Integration time step (s)

Dear Andre,

After I see what you have set up in the wind input file,I find the question.I think you should change the Usable Time to 630.it can’t be less than TMax.

Hope it can help you !

Best Regard

Ruiliang.Wang

I redid the wnd file with T = 630 and the same DT as in the fst file and now the simulation completes. Many thanks for the heads up.

The NRELOffshrBsline5MW_Floating.fst file works for me now but it throws out a warning:

WARNING message from DISCON.DLL:
Running with torque and pitch control of the NREL offshore 5MW baseline wind tur
bine from
DISCON.dll as written by J. Jonkman of NREL/NWTC for use in the IEA Annex XXIII
OC3 studies.
 Timestep: 495 of 630 seconds.  Estimated final completion at 15:20:39.
 WARNING:   Small angle assumption violated in SUBROUTINE SmllRotTrans() due to
a large blade
 deflection. The solution may be inaccurate. Simulation continuing, but future w
arnings will be
 suppressed.


 Total Real Time:       5.0038 minutes
 Total CPU Time:        4.9694 minutes
 Simulated Time:        10.5 minutes
 Time Ratio (Sim/CPU):  2.113

 FAST terminated normally.

So I be worried about the results here?

Dear Andre,

The small angle assumption violation warning has been discussed several times on this forum, for instance here: http://forums.nrel.gov/t/nrel-5mw-controls-dll-interface/183/1.

Best regards,

Many thanks for the link.

Is it possible to compile the BladedDLLInterface into the MATLAB/Simulink version of FAST, e.g. the S-Function using MinGW32 and not the Intel FORTRAN Compiler?

Andre,

I have never tried to use any GNU compiler with Matlab. A quick scan of the Matlab documentation shows that they do support GNU compilers for Linux/Mac but not Windows. It’s possible you could get it to work, but if you don’t have experience making Matlab mex functions, it’s probably a difficult task.

It works partly but gfortran complains about not finding some of the matlab routines but this is because of case-sensitivity.

Hello,

I am using fast v.8 with the “test 18.fst”, if I do not change any input I do not have any problem, but if I change the “TMax” to 100 I get the same error as it is explained at the beggining of this topic;I have tried to do what it is expalined, increase the “usable time” at the “90m_12mps_twr.inp” file but I get the same error. what is hapenning?

I do not know exactly how does it work, because the “NRELOffshrBsline5MW_Onshore_AeroDyn.dat” file calls to “90m_12mps_twr.bts”, but I have changed the .inp file since I can nor read the other file, so maybe the problem is here.

I have attached the .fst and inp files as .txt,( I will attach the .bts within other post)

thank you, best regards.
90m_12mps_twr_inp.txt (5.82 KB)
Test18.txt (3.91 KB)

Hello again,

I solved the problem!

thank you.

Hello,

I have started using FAST8, and I have just tried to run the 5MW wind turbine model, but the following message appears:

Could you help me fixing it, please?

Regards,

Iñaki

Dear Inaki,

Your problem sounds identical to the one solved recently in the following forum topic: http://forums.nrel.gov/t/error-running-fastv8/1171/1.

The land-based version of the NREL 5-MW turbine is available as Test18 in the CertTest of FAST v8.

Best regards,

Dear Jason,

first of all, thank you for your time. However, now I have some problems trying to run the Test18. When I run it, it starts running correctly, but it finds some kind of error and the following message appears:

I think it is related to the ServoData folder, but I am not sure. I would be so grateful if you could help me solving this problem.

Dear Inaki,

Running Test18 with the 64-bit version of the FAST v8 executable requires the use of a 64-bit version of the Bladed-style DLL controller (you can’t mix 32- and 64-bit addressing schemes). Change “DISCON_Win32.dll” to “DISCON_x64.dll” in the ServoDyn input file.

Best regards,

Dear Jason,

it works now. Thank you very much.

Regards,

Iñaki

Hello,

I have just tried to run the FAST file of the onshore 5MW wind turbine with the latest version of the software, but it returns me an error, although I have not changed anything. It says it finds an error while trying to read the Echo flag, and I do not know why, because the other files that I have run are written exactly in the same way, and they work.Could you please help me finding why is not working?

fast 5mw_2.png

Regards,

Iñaki

Dear Iñaki,

It doesn’t look like your FAST primary input file, “5MW_Onshore\NRELOffshrBsline5MW_Onshore.fst”, is in the proper format. What do the first few lines in this file look like?

Best regards,

Dear Jason,

the first lines of the file look like this:

Regards,

Iñaki