DTU 10-MW Reference Wind Turbine

Dear All,

I’m beginning research into optimizing offshore wind support structures and getting to know FAST. I was wondering if it would be possible to receive a copy of the DTU 10MW FAST model discussed in the above posts?

I’ve just begun to use the board so apologies in advance if I have missed a link to the model files.

Best Regards,
Kieran

Hello Kieran

Sorry for the late response to your question. There are some limitations in the model (the controller issue, for example, is mentioned above) and it’s not in a public stage yet. However, for use on own risk, I can provide the model, if you send me your mail adress.

Best regards
Jan

Hello Jan,

Thank you for the kind offer of sharing your model and discussing it’s limitations. I will send you my mail address directly.

Best Regards,
Kieran

EDIT: The old site in my original comment is now out of date. The files are now hosted on a GitLab repository here: https://rwt.windenergy.dtu.dk/dtu10mw/dtu-10mw-rwt. Note that, however, the FAST files might not necessarily match the HAWC2 files released on hawc2.dk/download/hawc2-model.

Original post:

Cheers,
Jenni

Hello everyone

Fortunately, this new model comprises a controller DLL without limitations. I’ve sent the DTU 10MW model to numerous people, so I suggest you all to use the files from the repository mentioned in the post before mine.

However, if someone is interested in a bottom-fixed support structure instead of the floating structure, I’ve attached a small archive with SubDyn and HydroDyn input files of the INNWIND.EU reference jacket. In comparison to the OC4 jacket model (Test21), this one incorporates joint cans and has therefore far more nodes/DOFs. Please note that it might be necessary to recalculate the tower mode shapes.

Best regards
Jan
INNWIND_RefJacket_FAST_SubDyn_HydroDyn_jha.zip (17.4 KB)

Dear all,

I’ve been trying to run the DTU 10MW RWT FAST files (as downloaded from the repository), however I’ve been having an issue with the controller since I keep getting an error after execution of the .fst: “…\dtu_we_controller_bladed. dll could not be loaded. Check that the file exists in the specified location and that it is compiled for 64-bit applications”. I also get the same error for 32-bit applications. Therefore, I would appreciate if you could share with me the corresponding file.

On the other hand, having this working I’m going to run the turbine on a Floating setting, which is why I was wondering if those files have been created yet and can be shared as well e.g., HydroDyn, MoorDyn, etc.

Best regards,

Ivan David Rojas
M.Sc. Sustainable Energy Technology
Wind Energy Track
Delft University of Technology - TU Delft

Dear all,

I’ve been trying to study the DTU 10 MW turbine on a fixed-bottom sub-structure like a jacket and a monopile. I’ve been using the FAST input file for the jacket sub-structure input files that Jan shared. For the normal operation analysis, I need a dll controller compiled with 64 bit. This is because the jacket model consiting of many nodes requires large memory. I’ve tried to compile it with 64 bit using the code file of the dll controller from GitHub, but the controller did not work properly with 64 bit executable of FASTv8. I am wondering if you guys can share a dll controller compiled with 64 bit.

I am also wondering if the FAST input files for the monopile sub-structure for DTU 10 MW turbine exists or can be shared if it exists. Does anyone use the input files(SubDyn and HydroDyn) for the monopile sub-structure for FASTv8? If so, it would be a big help. Thank you.

Best
Regards,

Semyung Park
PhD Candidate
Wind Energy Center
Mechanical and Industrial Engineering
University of Massachusetts Amherst
Amherst, MA 01003

Dear Semyung Park,

What do you mean when you say that, “the controller did not work properly”?

I’ll let someone else (who may have these files) respond regarding the SubDyn and HydroDyn files.

Best regards,

Dear all,
I am trying to compile the DTU 10-MW model using opencast on Mac OS. However the dtu_we_controller.dll cannot be read on a MacOS.
Does anyone know if a version of this library exists for mac ( .so) ? Is the source code available ?

Thank you very much for your help,

Romain Pinguet

Dear Romain and Semyung,

I am not involved with the project in any way but the source code of the controller is available here:
https://github.com/DTUWindEnergy/BasicDTUController

There is also a makefile, so if you run make on your Mac OS it should create the .so files that you need (it is set up such that it recognises the operating system you are using). A very simple explanation is also provided in the readme file here:
https://github.com/DTUWindEnergy/BasicDTUController/blob/master/src/Makefile.README.txt

Unfortunately I also didn’t manage to get this to work in 64bit. I re-compiled it using a 64bit compiler on Windows, but as soon as the analysis starts running, the controller stops with the error “NaN issue. Stop in DTU controller.”

I traced this error to the function PID2 inside the dtu_we_controller_fcns.f90:
https://github.com/DTUWindEnergy/BasicDTUController/blob/master/src/dtu_we_controller/dtu_we_controller_fcns.f90

The issue appears to be that PIDvar%outres is NaN initially, and the controller stops (?). However, the text that is plotted in the same if structure is also plotted for the working 32bit version of the controller, so the issue may be only the “stop” command inside the if structure in the PID2 function (however, I didn’t try changing this). The error I get is shown in the picture below.

In case someone else tries to compile it, I would greatly appreciate if he/she could let me know if it worked. That would help me understand whether the problem is with my compiler or somewhere in the code in the repository.

Kind regards,

Laszlo Arany

Dear Lazlo and others,

We experience the same NaN-issue for PIDvar%outres with the DTU controller when using 64bit compiler on Windows (ifort).

Has anyone managed to successfully compile 64bit in windows and run Fast with the DTU controller without (known) errors? It would be highly appreciated if she/he could share how the NaN-issue was solved.

Many thanks

Dear all,

One possible explanation of the NaN-issue experienced with the 64-bit DTU controller is the following:

The DISCON routine (in dtu_we_controller_bladed.f90) calls “update_regulation” in the initialization step. At initialization, the timestep, dt, equals zero which gives a NaN-number (divide by zero) in the PID2-function (dtu_we_controller_fcns.f90) and the controller stops due to an internal NaN-check.

Assuming that there is no reason for calling “update_regulation” at the initialization step, a quick fix is to extend the IF (callno.eq.0)-statement to IF-ELSE in the DISCON routine so that it calls “update_regulation” only if callno is not 0.

Example:
If (callno .eq. 0) then

… (various code lines)
call init_regulations_advanced(array1, array2)
… (various code lines)

else !Insert else statement, i.e. Continue only if (callno.ne.0)
!endif !Remove endif statement

… (various code lines)
call update_regulation(array1, array2)
… (various code lines)

endif !Insert endif statement here

If anyone knows a more robust solution, or believes that “update_regulation” needs to be called during initialization, please comment.

Dear Jason,

I am studying seismic response of DTU 10MW WT and NREL 5MW WT using FAST_7. As FAST_V8 can not simulate seismic response, I choose FAST_7 as my tool. So I need modify the model supplied by Jan at [url]http://forums.nrel.gov/t/dtu-10-mw-reference-wind-turbine/993/1] for FAST_7. After transforming the model of DTU 10MW WT from FAST_v8 to FAST_v7, I copy the controller file named dtu_we_controller.dll supplied by Jan which can run at FAST_V8 and renamed it as DISCON.dll. When running the analysis with FAST_V7, it aborting FAST with the prompt “The procedure DISCON could not be loaded” . There must be some mistake in my work. Could you give me some advice?

  1. Whether the controller dtu_we_controller.dll working at FAST_V8 normally can be used to FAST_V7 directly without any modify?
    2.If the answer of 1 is no,How can I build controller of DTU10MW for FAST_V7? In my opinion, I can accomplish it by changing the parameter at DISCON.f90 and compiling it . Is it correct?

Thank you.

Dear RenQiang.Xi,

You should be able to use the same DISCON controller in both FAST v7 and FAST v8. Regarding an error that the DLL could not be loaded, see the following topic on our forum: http://forums.nrel.gov/t/discon-dll-could-not-be-loaded/1386/2.

Best regards,

Dear Jason,
Actually, I have read the topic you supplied above.Firstly, I am sure DISCON.DLL is in the current working directory. And, the DISCON.DLL file is 32-bit as it is executable with with 32-bit FAST_V8. Perhaps,this situation is related to the dtu_we_controller.dll file.

So, I change DISCON.f90 for DTU10MW and compile it. Now, the new DISCON.DLL file which was compiled from DISCON.f90 is working with FAST_V7. As I am not familiar with controller, I need more time to change DISCON.f90 for DTU10MW.

Thank you!

Dear RenQiang,

I am also trying to run FAST (v8.16.00a-bjj, 32-bit) with the DTU 10 MW and the controller (dtu_we_controller.dll) and I have got the same issue: it aborting FAST with the prompt “The procedure DISCON could not be loaded”. I am sure DISCON.DLL is in the current working directory.

Does anyone has a solution to this issue? Maybe should I downgrade to the FAST version 8.12?

Thanks a lot,

Dear Marie,

I understood from RenQiang’s post that the problem was with the dtu_we_controller.dll, not with FAST. I would not expect a DLL controller that works with FAST v7 would not also work with FAST v8. But I’ll let RenQiang comment further.

Best regards,

Actually, I can run FAST (v8.16.00a-bjj, 32-bit) with the DTU 10 MW and the controller (dtu_we_controller.dll). If you can not, you can try running it with Windows cmd.exe using admin User.

Dear all,

I’m trying to find the DTU 10-MW reference wind turbine input files for FAST. As recommended in this forum I tried to create an account in dtu-10mw-rwt.vindenergi.dtu.dk/ but haven’t got any response in a long time. Does anyone know where to find these files? Mainly the blade properties and control related files.

Thank you very much for your help,

Jose Vazquez

Dear all,

First, thanks a lot Jason and RenQiang for your previous answers. I thought that my problem was solved: the “admin User” trick did not work but I found a configuration with 2 dll and a control data folder which was recognised by FAST. However, when I look at simple steady winds to check my thrust curve, the behaviour of my turbine is not very encouraging: I can observe a shut down of the turbine for all wind speeds between 6 m/s and 25 m/s… :neutral_face:

I have two different assumption regarding this issue:

  • my controller file is not the good one,
  • my servodyn file has wrong parameters.

Since I have also the same problem as Jose to create a new account on the DTU website (and then to check my data files), I therefore joint the request of Jose: would it be possible to provide us a FAST example of a basic simulation for the DTU 10 MW with the suitable controller?

Thanks a lot and sorry to re-open again this subject.